Bug 589581 - NetworkManager will not let the use enter a Gateway when editing an existing interface's ipv4 properties
Summary: NetworkManager will not let the use enter a Gateway when editing an existing ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager
Version: 6.0
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Dan Williams
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 13:26 UTC by Karanbir Singh
Modified: 2010-05-06 23:16 UTC (History)
1 user (show)

Fixed In Version: NetworkManager-0.8-12.git20100504.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-06 23:16:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Karanbir Singh 2010-05-06 13:26:17 UTC
Description of problem:
When editing the ipv4 properties for an existing connection in NetworkManager its impossible to enter a default gateway. 

Version-Release number of selected component (if applicable):
NetworkManager-glib-0.7.997-1.el6.x86_64
NetworkManager-gnome-0.7.997-1.el6.x86_64
NetworkManager-0.7.997-1.el6.x86_64

How reproducible:
Reproduceable everytime

Steps to Reproduce:
1.Connect machine to lan
2.NM sets up an Auto mode and dhcp's
3.Right click on NM icon in the notification area
4.select Edit connections
5. select 'Auto eht0' and click edit
6. on the ipv4 tab, select manual and click add
7. Enter 'Address -> 192.168.1.32', 'Netmask -> 255.255.255.0', 'Gateway -> 192.168.1.1'.
Actual results:

1. Navigate to the DNS Servers: box, and Gateway entry is reset to '0.0.0.0'
2. Enter DNS sever -> 192.168.1.3; click back to edit Gateway, enter '192.168.1.1'.
3. Shift focus to any other component on that window, and the gateway is reset to '0.0.0.0'
  
Expected results:
Navigating away from the Gateway entry should not reset the contents to '0.0.0.0'

Additional info:

Comment 2 RHEL Program Management 2010-05-06 14:45:23 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Dan Williams 2010-05-06 23:16:17 UTC
This is due to GTK's tree-view editing handling; and has since been fixed upstream and in recent RHEL6 builds.  It should be fixed in RHEL6 Beta 2 snapshots or anything after 2010-05-05.

Upstream network-manager-applet commit:

commit cb9d7f232e2661c34d0183c03fbe9a470bc1988f
Author: cee1 <fykcee1@gmail.com>
Date:   Mon Apr 26 23:42:43 2010 -0700

    editor: commit IPv6 address changes on focus-out
    
    Cleanups and fixes by dcbw.


Note You need to log in before you can comment on or make changes to this bug.