Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 589641 - mvapich-1.2.0-0.3562.1.el5.src.rpm does not have Fortran support
Summary: mvapich-1.2.0-0.3562.1.el5.src.rpm does not have Fortran support
Keywords:
Status: CLOSED DUPLICATE of bug 584218
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mvapich
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jay Fenlason
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 15:33 UTC by Petr Lautrbach
Modified: 2014-08-31 23:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-09 17:09:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Petr Lautrbach 2010-05-06 15:33:02 UTC
This is originated on message from Platform preparing RH HPC 5.5:

We have found that the mvapich rpm (mvapich-1.2.0-0.3562.1.el5.src.rpm )
in RHEL 5.5 does not have Fortran support. We require fortran support to
be present for this package in order for us to compile fortran packages
against it.


My observation:
Configure is already run with --enable-f77 --enable-f90
./configure --enable-sharedlib --with-device=ch_gen2 --with-arch=LINUX -prefix=/usr/lib/mvapich/1.2.0-gcc --with-echo --enable-f77 --enable-f90 --with-romio '-lib=-libverbs -libumad -lpthread -Wall' -mpe_opts=--with-cflags=-m32 --with-fflags=-m32

but fortran seems to be disabled during "Configuring Fortran subsystem":
configure: warning: Could not find a way to access the command line from Fortran 77
configure: error: Command line access is required for MPICH
Error configuring the Fortran subsystem!
Turning off Fortran support

Comment 1 Jay Fenlason 2011-02-09 17:09:14 UTC

*** This bug has been marked as a duplicate of bug 584218 ***


Note You need to log in before you can comment on or make changes to this bug.