Bug 589647 - [abrt] crash in bash-4.1.2-2.el6: Process /bin/bash was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in bash-4.1.2-2.el6: Process /bin/bash was killed by signal 11 (...
Keywords:
Status: CLOSED DUPLICATE of bug 587587
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bash
Version: 6.0
Hardware: s390x
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Roman Rakus
QA Contact: BaseOS QE - Apps
URL:
Whiteboard: abrt_hash:f1125ce8eaedeb66cb8ba8cfae1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 15:40 UTC by Michal Nowak
Modified: 2014-01-13 00:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-06 16:30:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: backtrace (19.56 KB, text/plain)
2010-05-06 15:40 UTC, Michal Nowak
no flags Details

Description Michal Nowak 2010-05-06 15:40:27 UTC
abrt 1.0.9 detected a crash.

architecture: s390x
Attached file: backtrace
cmdline: /bin/sh -c 'echo | /root/rpmbuild/BUILD/gcc-4.4.4-20100503/obj-s390x-redhat-linux/./gcc/xgcc -B/root/rpmbuild/BUILD/gcc-4.4.4-20100503/obj-s390x-redhat-linux/./gcc/ -E -dM - | \\\n  sed -n -e \'s/^#define \\([^_][a-zA-Z0-9_]*\\).*/\\1/p\' \\\n\t -e \'s/^#define \\(_[^_A-Z][a-zA-Z0-9_]*\\).*/\\1/p\' | \\\n  sort -u > tmp-macro_list'
component: bash
executable: /bin/bash
global_uuid: f1125ce8eaedeb66cb8ba8cfae1d1c56b6299821
kernel: 2.6.32-23.el6.s390x
package: bash-4.1.2-2.el6
rating: 4
reason: Process /bin/bash was killed by signal 11 (SIGSEGV)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)

Comment 1 Michal Nowak 2010-05-06 15:40:29 UTC
Created attachment 412097 [details]
File: backtrace

Comment 2 Michal Nowak 2010-05-06 15:43:49 UTC
Was rebuilding gcc srpm and this segfault stopped that rebuild:

[...]
# @multilib_flags@ is still needed because this may use
# /root/rpmbuild/BUILD/gcc-4.4.4-20100503/obj-s390x-redhat-linux/./gcc/xgcc -B/root/rpmbuild/BUILD/gcc-4.4.4-20100503/obj-s390x-redhat-linux/./gcc/ -B/usr/s390x-redhat-linux/bin/ -B/usr/s390x-redhat-linux/lib/ -isystem /usr/s390x-redhat-linux/include -isystem /usr/s390x-redhat-linux/sys-include    and -O2  -O2 -g -pipe -Wall -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=z9-109 -mtune=z10 -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wcast-qual -Wold-style-definition  -isystem ./include  -fPIC -mlong-double-128 -g -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED  directly.
# @multilib_dir@ is not really necessary, but sometimes it has
# more uses than just a directory name.
/bin/sh ../../../libgcc/../mkinstalldirs .
/root/rpmbuild/BUILD/gcc-4.4.4-20100503/obj-s390x-redhat-linux/./gcc/xgcc -B/root/rpmbuild/BUILD/gcc-4.4.4-20100503/obj-s390x-redhat-linux/./gcc/ -B/usr/s390x-redhat-linux/bin/ -B/usr/s390x-redhat-linux/lib/ -isystem /usr/s390x-redhat-linux/include -isystem /usr/s390x-redhat-linux/sys-include    -O2  -O2 -g -pipe -Wall -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=z9-109 -mtune=z10 -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wcast-qual -Wold-style-definition  -isystem ./include  -fPIC -mlong-double-128 -g -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED  -shared -nodefaultlibs -Wl,--soname=libgcc_s.so.1 -Wl,--version-script=libgcc.map -o ./libgcc_s.so.1.tmp -O2 -g -pipe -Wall -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=z9-109 -mtune=z10 -B./ _muldi3_s.o _negdi2_s.o _lshrdi3_s.o _ashldi3_s.o _ashrdi3_s.o _cmpdi2_s.o _ucmpdi2_s.o _clear_cache_s.o _enable_execute_stack_s.o _trampoline_s.o __main_s.o _absvsi2_s.o _absvdi2_s.o _addvsi3_s.o _addvdi3_s.o _subvsi3_s.o _subvdi3_s.o _mulvsi3_s.o _mulvdi3_s.o _negvsi2_s.o _negvdi2_s.o _ctors_s.o _ffssi2_s.o _ffsdi2_s.o _clz_s.o _clzsi2_s.o _clzdi2_s.o _ctzsi2_s.o _ctzdi2_s.o _popcount_tab_s.o _popcountsi2_s.o _popcountdi2_s.o _paritysi2_s.o _paritydi2_s.o _powisf2_s.o _powidf2_s.o _powixf2_s.o _powitf2_s.o _mulsc3_s.o _muldc3_s.o _mulxc3_s.o _multc3_s.o _divsc3_s.o _divdc3_s.o _divxc3_s.o _divtc3_s.o _bswapsi2_s.o _bswapdi2_s.o _fixunssfsi_s.o _fixunsdfsi_s.o _fixunsxfsi_s.o _fixsfdi_s.o _fixdfdi_s.o _fixxfdi_s.o _fixtfdi_s.o _fixunssfdi_s.o _fixunsdfdi_s.o _fixunsxfdi_s.o _fixunstfdi_s.o _floatdisf_s.o _floatdidf_s.o _floatdixf_s.o _floatditf_s.o _floatundisf_s.o _floatundidf_s.o _floatundixf_s.o _floatunditf_s.o _divdi3_s.o _moddi3_s.o _udivdi3_s.o _umoddi3_s.o _udiv_w_sdiv_s.o _udivmoddi4_s.o unwind-dw2_s.o unwind-dw2-fde-glibc_s.o unwind-sjlj_s.o gthr-gnat_s.o unwind-c_s.o emutls_s.o -lc && rm -f ./libgcc_s.so && if [ -f ./libgcc_s.so.1 ]; then mv -f ./libgcc_s.so.1 ./libgcc_s.so.1.backup; else true; fi && mv ./libgcc_s.so.1.tmp ./libgcc_s.so.1 && ln -s libgcc_s.so.1 ./libgcc_s.so
/bin/sh: line 1:  4985 Segmentation fault      (core dumped) /root/rpmbuild/BUILD/gcc-4.4.4-20100503/obj-s390x-redhat-linux/./gcc/xgcc -B/root/rpmbuild/BUILD/gcc-4.4.4-20100503/obj-s390x-redhat-linux/./gcc/ -B/usr/s390x-redhat-linux/bin/ -B/usr/s390x-redhat-linux/lib/ -isystem /usr/s390x-redhat-linux/include -isystem /usr/s390x-redhat-linux/sys-include -O2 -O2 -g -pipe -Wall -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=z9-109 -mtune=z10 -DIN_GCC -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wcast-qual -Wold-style-definition -isystem ./include -fPIC -mlong-double-128 -g -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED -shared -nodefaultlibs -Wl,--soname=libgcc_s.so.1 -Wl,--version-script=libgcc.map -o ./libgcc_s.so.1.tmp -O2 -g -pipe -Wall -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=z9-109 -mtune=z10 -B./ _muldi3_s.o _negdi2_s.o _lshrdi3_s.o _ashldi3_s.o _ashrdi3_s.o _cmpdi2_s.o _ucmpdi2_s.o _clear_cache_s.o _enable_execute_stack_s.o _trampoline_s.o __main_s.o _absvsi2_s.o _absvdi2_s.o _addvsi3_s.o _addvdi3_s.o _subvsi3_s.o _subvdi3_s.o _mulvsi3_s.o _mulvdi3_s.o _negvsi2_s.o _negvdi2_s.o _ctors_s.o _ffssi2_s.o _ffsdi2_s.o _clz_s.o _clzsi2_s.o _clzdi2_s.o _ctzsi2_s.o _ctzdi2_s.o _popcount_tab_s.o _popcountsi2_s.o _popcountdi2_s.o _paritysi2_s.o _paritydi2_s.o _powisf2_s.o _powidf2_s.o _powixf2_s.o _powitf2_s.o _mulsc3_s.o _muldc3_s.o _mulxc3_s.o _multc3_s.o _divsc3_s.o _divdc3_s.o _divxc3_s.o _divtc3_s.o _bswapsi2_s.o _bswapdi2_s.o _fixunssfsi_s.o _fixunsdfsi_s.o _fixunsxfsi_s.o _fixsfdi_s.o _fixdfdi_s.o _fixxfdi_s.o _fixtfdi_s.o _fixunssfdi_s.o _fixunsdfdi_s.o _fixunsxfdi_s.o _fixunstfdi_s.o _floatdisf_s.o _floatdidf_s.o _floatdixf_s.o _floatditf_s.o _floatundisf_s.o _floatundidf_s.o _floatundixf_s.o _floatunditf_s.o _divdi3_s.o _moddi3_s.o _udivdi3_s.o _umoddi3_s.o _udiv_w_sdiv_s.o _udivmoddi4_s.o unwind-dw2_s.o unwind-dw2-fde-glibc_s.o unwind-sjlj_s.o gthr-gnat_s.o unwind-c_s.o emutls_s.o -lc
make[3]: *** [libgcc_s.so] Error 139
make[3]: Leaving directory `/root/rpmbuild/BUILD/gcc-4.4.4-20100503/obj-s390x-redhat-linux/s390x-redhat-linux/libgcc'
make[2]: *** [all-stage1-target-libgcc] Error 2
make[2]: Leaving directory `/root/rpmbuild/BUILD/gcc-4.4.4-20100503/obj-s390x-redhat-linux'
make[1]: *** [stage1-bubble] Error 2
make[1]: Leaving directory `/root/rpmbuild/BUILD/gcc-4.4.4-20100503/obj-s390x-redhat-linux'
make: *** [profiledbootstrap] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.goFq9A (%build)
[...]

Another crash which happened during rebuild but abrt decided it's different one: https://bugzilla.redhat.com/show_bug.cgi?id=589649

Comment 4 Roman Rakus 2010-05-06 16:30:52 UTC

*** This bug has been marked as a duplicate of bug 587587 ***


Note You need to log in before you can comment on or make changes to this bug.