Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 589667 - VDSM: VM stuck at "Migration Destination" status forever ( due to python deadlock )
Summary: VDSM: VM stuck at "Migration Destination" status forever ( due to python dead...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python
Version: 5.5
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Dave Malcolm
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 16:06 UTC by Oded Ramraz
Modified: 2016-04-26 13:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-21 04:37:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
parent process core (2.88 MB, application/x-xz)
2010-05-06 16:06 UTC, Oded Ramraz
no flags Details
child process core (2.78 MB, application/x-xz)
2010-05-06 16:06 UTC, Oded Ramraz
no flags Details

Description Oded Ramraz 2010-05-06 16:06:11 UTC
Created attachment 412105 [details]
parent process core

Description of problem:

After running multiple migrations from host A to host B one of the guests stuck at "Migration Destination" status forever.
After running "pgrep vdsm" command on the host i noticed that there are 3 vdsm processes instead of two. 

According to danken@redhat.com this issue happen due to python deadlock. 


Version-Release number of selected component (if applicable):

vdsm22-4.5-54.101870224

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Oded Ramraz 2010-05-06 16:06:55 UTC
Created attachment 412107 [details]
child process core

Comment 3 Dan Kenigsberg 2010-05-06 16:30:29 UTC
To be more exact: following the backtrace of the child process hints that it was created by subprocess module. Before the expected exec(), garbage collection fired, and vdsm's task.Task.__del__ was called. The latter blocks deep inside logging module.

It might be a bug in one of the mentioned python modules, or that logging should not be used in __del__, or something completely different.

Comment 4 Ayal Baron 2010-05-12 05:47:14 UTC
Please attach vdsm log.

Comment 5 Dave Malcolm 2010-05-24 16:34:19 UTC
Do you have a link to the .py code that's being executed?

Comment 6 Dan Kenigsberg 2010-05-25 06:43:47 UTC
http://bob.eng.lab/builds/sm64/vdsm22-4.5-54.el5rhev.x86_64.rpm should be pretty close.

Comment 8 RHEL Program Management 2011-09-23 00:34:52 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 10 RHEL Program Management 2013-03-21 04:37:08 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 11 Dan Kenigsberg 2013-03-21 07:40:59 UTC
I don't mind this bug closure, as we are using https://pypi.python.org/pypi/cpopen for quite some time in order to avoid this issue (and others).


Note You need to log in before you can comment on or make changes to this bug.