Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 589670 - spice: Ensure ring data is save/restored on migration
spice: Ensure ring data is save/restored on migration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Alon Levy
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 12:19 EDT by Amit Shah
Modified: 2014-08-04 18:08 EDT (History)
5 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.63.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:24:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Shah 2010-05-06 12:19:10 EDT
Description of problem:

The current patches for spice-vmc don't save/restore guest or libspice data across migration, which will lead to data loss and unexpected conditions.
Comment 3 Alon Levy 2010-05-16 04:52:34 EDT
The patch currently in the queue isn't the latest, but generally the patch that should be here removes the ring so the bug is fixed in the empty sense.

That said, testing should include migrating a machine and verifying all the functionality that vdagent supplies works after. That functionality is a mouse channel and automatic resize of screen when spiceclient connects with right flag.
Comment 8 lihuang 2010-08-03 11:32:59 EDT
currently we can not verify this bug on the latest qemu-kvm version (-106.el6) due to bug#618168.
I have test migration(both live and offline) on -78.el6 with spicevmc device. PASS
setting to verified. please create new bug if problem is detected in later version.
Comment 9 releng-rhel@redhat.com 2010-11-10 16:24:50 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.