Bug 589688 - KeyError: 'ID_PATH'
KeyError: 'ID_PATH'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Harald Hoyer
Yulia Kopkova
anaconda_trace_hash:8a388a3a231a17f48...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 13:19 EDT by Michal Schmidt
Modified: 2010-11-10 16:49 EST (History)
1 user (show)

See Also:
Fixed In Version: udev-147-2.15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 589717 (view as bug list)
Environment:
Last Closed: 2010-11-10 16:49:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (52.89 KB, text/plain)
2010-05-06 13:19 EDT, Michal Schmidt
no flags Details

  None (edit)
Description Michal Schmidt 2010-05-06 13:19:44 EDT
The following was filed automatically by anaconda:
anaconda 13.21.35 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/udev.py", line 293, in udev_device_get_path
    return info["ID_PATH"]
  File "/usr/lib/anaconda/storage/devices.py", line 155, in deviceNameToDiskByPath
    return udev_device_get_path(dev)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1360, in handleUdevDiskLabelFormat
    bypath = os.path.basename(deviceNameToDiskByPath(device.name))
  File "/usr/lib/anaconda/storage/devicetree.py", line 1715, in handleUdevDeviceFormat
    self.handleUdevDiskLabelFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1299, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1965, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 379, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 103, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1346, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1259, in nextClicked
    self.setScreen ()
KeyError: 'ID_PATH'
Comment 1 Michal Schmidt 2010-05-06 13:19:48 EDT
Created attachment 412119 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2010-05-06 13:23:32 EDT
Looks like virtio devices aren't providing ID_PATH again.
Comment 3 Michal Schmidt 2010-05-06 13:25:46 EDT
I attempted an installation in a KVM guest, started from boot.iso. I gave Anaconda the HTTP URL where it then downloaded install.img from. The graphical Anaconda started, notified me that I'm installing a beta, asked about the storage method, at which point I chose the basic one. Then it crashed.
Comment 5 RHEL Product and Program Management 2010-05-06 14:37:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Harald Hoyer 2010-05-07 04:10:17 EDT
should be fixed with udev-147-2.15
Comment 10 releng-rhel@redhat.com 2010-11-10 16:49:28 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.