Bug 589689 - Dynamically load tgt_drivers and package tgt-iser separately, for proper dependencies
Dynamically load tgt_drivers and package tgt-iser separately, for proper depe...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scsi-target-utils (Show other bugs)
6.0
i386 Linux
low Severity low
: rc
: ---
Assigned To: Andy Grover
Storage QE
: FutureFeature
Depends On:
Blocks: 767187 697866 846704
  Show dependency treegraph
 
Reported: 2010-05-06 13:19 EDT by Vesselin Kolev
Modified: 2012-08-08 15:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 15:04:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vesselin Kolev 2010-05-06 13:19:57 EDT
Description of problem:

When starting tgtd, the following error is logged in syslog (/var/log/messages):

tgtd: libibverbs.so: cannot open shared object file: No such file or directory - iser transport not used

The solution is either to build RPM package with dependence "Requires: libibverbs-devel" or to redesign libibverbs in the way to make symlink:

/usr/lib/libibverbs.so -> /usr/lib/libibverbs.so.1


Version-Release number of selected component (if applicable):

0.9.11-1.20091205snap.el6

How reproducible:

Always

Steps to Reproduce:

1. Make some configuration in /etc/tgt/targets.conf
2. Start service (tgtd daemon):

# service tgtd start

  
Actual results:

Daemon starts, but error is logged in syslog.

Expected results:

Clean start with no errors of this kind.

Additional info:
Comment 2 Mike Christie 2010-05-06 13:39:05 EDT
(In reply to comment #0)
> Description of problem:
> 
> When starting tgtd, the following error is logged in syslog
> (/var/log/messages):
> 
> tgtd: libibverbs.so: cannot open shared object file: No such file or directory
> - iser transport not used
> 

This error is fine if you are not using iser. If you are using iser then you should install libibverbs.

Are you trying to use iser or do you have libibverbs and it is not working?
Comment 3 Vesselin Kolev 2010-05-06 14:23:34 EDT
Yes, I'm trying to use iser. But I have libibverbs installed:

[vesso@mahadeva ~]$ rpm -ql libibverbs
/etc/libibverbs.d
/usr/lib/libibverbs.so.1
/usr/lib/libibverbs.so.1.0.0
/usr/share/doc/libibverbs-1.1.3
/usr/share/doc/libibverbs-1.1.3/AUTHORS
/usr/share/doc/libibverbs-1.1.3/COPYING
/usr/share/doc/libibverbs-1.1.3/ChangeLog
/usr/share/doc/libibverbs-1.1.3/README

The described problem is solved by installing libibverbs-devel (provides /usr/lib/libibverbs.so):

[vesso@mahadeva ~]$ rpm -ql libibverbs-devel
...
/usr/lib/libibverbs.so
...
Comment 4 RHEL Product and Program Management 2010-05-06 14:37:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Mike Christie 2010-05-06 14:48:26 EDT
(In reply to comment #3)
> Yes, I'm trying to use iser. But I have libibverbs installed:
> 

Ah I see what you are saying.

I did not want to add the requires to scsi-target-utils rpm because it would force users of just iscsi to bring in all the ib stuff.

I am trying to break out the iser code and make it lib and add it to a separate rpm which would have the required requires. So you could do

// install core target
yum install scsi-target-utils
// install iser handler for target
yum install scsi-target-iser-utils

And that would bring in and install everything needed.
Comment 6 Vesselin Kolev 2010-05-06 15:06:01 EDT
I agree with You! In such case splitting of the package is the only way.

Thank You a lot!!!
Comment 7 Mike Christie 2010-05-06 15:19:51 EDT
Ok. It is too close to RHEL 6 release time to do this, so I am putting this up for RHEL 6.1 and adding a devel ack. You can track the progress in this bugzilla. Thanks for the bug report!
Comment 8 Mike Christie 2010-05-07 21:45:42 EDT
*** Bug 589803 has been marked as a duplicate of this bug. ***
Comment 10 Mike Christie 2011-02-01 03:52:43 EST
This is not getting done for 6.1, because upstream just completed a completely new iser target for stgt.
Comment 13 Andy Grover 2011-12-20 16:19:06 EST
implemented in rawhide, but we may or may not want to backport this to rhel6.
Comment 18 RHEL Product and Program Management 2012-07-10 02:07:13 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 19 RHEL Product and Program Management 2012-07-10 21:54:11 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 20 Andy Grover 2012-08-08 15:04:37 EDT
atm scsi-target-utils depends on ib stuff. I don't think it's worth diverging from upstream just to eliminate dependencies on two small packages. closing wontfix.

Note You need to log in before you can comment on or make changes to this bug.