Bug 58971 - pico is broken for Chinese, Japanese, Korean
pico is broken for Chinese, Japanese, Korean
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-28 14:50 EST by Nakai
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-01 01:56:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Multibyte fix for pico (3.62 KB, patch)
2002-01-28 14:51 EST, Nakai
no flags Details | Diff

  None (edit)
Description Nakai 2002-01-28 14:50:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
pico editor is broken for CJK multibytes and really shameless
because RHL product manuals explains how to use pico but
Asian users cannot use it.

A Patch is available.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Input Japanese
2.shoot
3.
	

Additional info:
Comment 1 Nakai 2002-01-28 14:51:19 EST
Created attachment 43816 [details]
Multibyte fix for pico
Comment 2 Mike A. Harris 2002-01-29 01:31:31 EST
Patch added to pine 4.44-4 in rawhide.
Comment 3 terbak 2002-03-16 19:04:18 EST
This patch is way broken with pine: the word-wrapping is broken, backspace on 
first column does not bring the text up one line, and pine crashes when writing 
a bit.
Comment 4 Mike A. Harris 2002-03-17 11:37:37 EST
Indeed.  Patch removed from pine-4.44-6 release for stabilization.
At this point I will not permit this patch to be included as it can
interfere with the standard operation of PINE.  Such enhancements
should be made by submitting patches to the PINE team themselves.

Thanks terbak for tracking the wordwrap problem down.
Comment 5 Nakai 2002-03-18 02:51:31 EST
I'll continue for the future product release.
Comment 6 Mike A. Harris 2002-11-01 01:56:22 EST
Closing bug WONTFIX

pine/pico aren't true open source software, and dedicating resources
to issues like this isn't a priority because of that, in particular
when there are tonnes of other editors available that can be used
instead.

Note You need to log in before you can comment on or make changes to this bug.