Bug 589720 - Uninventorying an EAP server, restarting it w/ a different JDK and rediscovering reuses JAVA_HOME from stale inventory. [NEEDINFO]
Summary: Uninventorying an EAP server, restarting it w/ a different JDK and rediscover...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins   
(Show other bugs)
Version: 1.4
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: jon-sprint10-bugs
TreeView+ depends on / blocked
 
Reported: 2010-05-06 18:17 UTC by Corey Welton
Modified: 2014-05-02 17:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-02 17:44:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cwelton: needinfo? (ccrouch)


Attachments (Terms of Use)

Description Corey Welton 2010-05-06 18:17:31 UTC
Description of problem:
If a user uninventories an EAP which is running on one JDK (e.g., Java 5), removes it from inventory, restarts it with a newer/different JDK (e.g., Java 6), it is returned to inventory but maintains the JAVA_HOME from the initial discovery.


Version-Release number of selected component (if applicable):
1.4

How reproducible:


Steps to Reproduce:
1.  Assure you have two JDKs installed, i.e., "/opt/jdk1.5.0_22" and "/opt/jdk1.6.0_20"
2.  Start an EAP using one of the JDKs (/opt/jdk1.5.0_22); discover and add to inventory; assure it goes green.
3.  Stop EAP and remove from inventory.
4.  Relaunch EAP, this time using a different JDK (/opt/jdk1.6.0_20); add to inventory (though it might auto-add since the key is the same as the stale item).
5. Click the Inventory > Connection subtab of the EAP server.
6. View the value of "JAVA_HOME Path"
  
Actual results:

The value of the stale, older inventory persists to the newer one.

Expected results:

The appropriate value of the newly inventoried EAP should be populated in the field.

Additional info:

Comment 1 Corey Welton 2010-09-24 12:24:54 UTC
ccrouch - is this something we want to officially support?


Note You need to log in before you can comment on or make changes to this bug.