Bug 589760 - EL6 Kernel Needs IMA API Cleanup
EL6 Kernel Needs IMA API Cleanup
Status: CLOSED DUPLICATE of bug 584901
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 16:18 EDT by Jason McCormick
Modified: 2011-05-04 18:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-04 18:26:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason McCormick 2010-05-06 16:18:49 EDT
Description of problem:

The kernel shipping with EL6 because implements Integrity Management Architecture (IMA).  It appears that the 2.6.32 kernel provided in EL6 beta has an early, flawed version of the API.  The API only allows GPL modules to call ima_counts_get() with leaves non-GPL modules no way to legitimately use dentry_open() and fput() combinations correctly.  This causes a big problem for, among other things, users of OpenAFS.  Here's the OpenAFS project's description of the problem:

<https://lists.openafs.org/pipermail/openafs-announce/2010/000333.html>

The kernel/IMA developers have acknowledged this problem and addressed the API issues in 2.6.33.  Red Hat, please backport the updated IMA API, notably the following kernel changes into EL6 before its production release:

  0552f879: Untangling ima mess, part 1: alloc_file()
  b65a9cfc: Untangling ima mess, part 2: deal with counters
  1429b3ec: Untangling ima mess, part 3: kill dead code in ima
Comment 1 Jason McCormick 2010-05-06 16:56:41 EDT
This is a duplicate of Bug 584901.  Sorry for the noise, i missed it in the first searches about this.
Comment 3 RHEL Product and Program Management 2010-05-06 18:12:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 RHEL Product and Program Management 2010-07-15 10:39:32 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 John Feeney 2011-05-04 18:26:57 EDT
Since the reporter wrote that this is a duplicate of another bugzilla (see comment #1), which is now closed current release, I am going to close this now. Please re-open if needed.

*** This bug has been marked as a duplicate of bug 584901 ***

Note You need to log in before you can comment on or make changes to this bug.