This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 58977 - data +%k returns leading space for values 0-9
data +%k returns leading space for values 0-9
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: sh-utils (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-28 15:22 EST by Jaroslaw Sosnicki
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-28 15:22:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Sosnicki 2002-01-28 15:22:29 EST
Description of Problem:
data +%k returns leading space for hours 0-9
i.e date +%M%k for k=0-9 should return '029'
it returns '02 9' 

When used in file creation base on timestamp it fails since introduces unquoted
 blank space in file name

Version-Release number of selected component (if applicable):
sh-utils-2.0.11-9

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Bernhard Rosenkraenzer 2002-01-31 09:06:36 EST
+%k is supposed to do just that. You probably want to use +%H instead.

Note You need to log in before you can comment on or make changes to this bug.