Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 589782 - dracut cmdline options should be present in the check0 isolinux section too
dracut cmdline options should be present in the check0 isolinux section too
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: livecd-tools (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks: 705163
  Show dependency treegraph
 
Reported: 2010-05-06 16:58 EDT by Hans de Goede
Modified: 2016-04-26 10:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: livecd-tools-031-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 589778
Environment:
Last Closed: 2011-12-12 13:09:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2010-05-06 16:58:51 EDT
+++ This bug was initially created as a clone of Bug #589778 +++

There are some special dracut cmdline options added to isolinux.cfg by livecd tools, but only to the linux0 section, these options should be present in the check0 section too.
Comment 2 RHEL Product and Program Management 2010-05-06 18:12:38 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 RHEL Product and Program Management 2011-01-07 10:59:15 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 Brian Lane 2011-06-03 16:08:50 EDT
Fixed upstream in commit c832a6db4a1f916ca2816496f65a790c3f1ab6bb
Comment 9 Jay Greguske 2011-08-18 15:06:05 EDT
Handed off to RHEV build folks.
Comment 11 Jay Greguske 2011-11-18 11:28:41 EST
The RHEV-H developers may know more about this than I. I have not been testing explicitly for this bug.
Comment 12 Alan Pevec 2011-11-18 16:10:25 EST
RHEV-H kickstart removes check0 section, so frankly we don't care.
But looking at RHEL6.2-20111117.0-Workstation-x86_64-Live.iso I can verify this bug is fixed:

label linux0
  menu label Boot
  kernel vmlinuz0
  append initrd=initrd0.img root=live:CDLABEL=RHEL6.2-20111117.0-Workstation-x rootfstype=auto ro liveimg quiet  rhgb rd_NO_LUKS rd_NO_MD rd_NO_DM 
menu default
label check0
  menu label Verify and Boot
  kernel vmlinuz0
  append initrd=initrd0.img root=live:CDLABEL=RHEL6.2-20111117.0-Workstation-x rootfstype=auto ro liveimg quiet  rhgb rd_NO_LUKS rd_NO_MD rd_NO_DM check
Comment 13 Jan Stodola 2011-11-21 06:23:34 EST
Commit from comment 7 is applied in livecd-tools-031-4.el6.

check0 section for RHEL6.2-20111117.0-Workstation-x86_64-Live.iso contains additional dracut parameters (thank you Alan).

Moving this bug to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.