This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 589853 - [LXC] Disable 'autostart' doesn't take effect actually
[LXC] Disable 'autostart' doesn't take effect actually
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
:
Depends On:
Blocks: Rhel6.1LibvirtTier1
  Show dependency treegraph
 
Reported: 2010-05-07 01:50 EDT by zhanghaiyan
Modified: 2010-12-15 00:15 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-11 11:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhanghaiyan 2010-05-07 01:50:50 EDT
Description of problem:
Disable the 'autostart' for a running guest, it seems take effect when checking dominfo. But after restart libvirtd service, the guest is stilling running as 'autostart' is enabled.

Version-Release number of selected component (if applicable):
- kernel-2.6.32-24.el6.i686
- libvirt-0.8.1-1.el6.i686

How reproducible:
Always

Steps to Reproduce:
1. # cat vm1.xml
<domain type='lxc'>
	<name>vm1</name>
	<memory>500000</memory>
	<os>
		<type>exe</type>
		<init>/bin/sh</init>
	</os>
	<vcpu>1</vcpu>
	<clock offset='utc'/>
	<on_poweroff>destroy</on_poweroff>
	<on_reboot>restart</on_reboot>
	<on_crash>destroy</on_crash>
	<devices>
		<emulator>/usr/libexec/libvirt_lxc</emulator>
		<interface type='network'>
			<source network='default'/>
		</interface>
		<console type='pty' />
	</devices>
</domain>
2. # virsh define vm1.xml

3. # virsh start vm1
Domain vm1 started

4.# virsh list --all
 Id Name                 State
----------------------------------
4584 vm1                  running
  - fedora-rawhide       shut off

5. # virsh dominfo vm1
Id:             4584
Name:           vm1
UUID:           c53ea2c3-8291-b6e0-ee4f-329ef23944b2
OS Type:        exe
State:          running
CPU(s):         1
CPU time:       0.0s
Max memory:     500000 kB
Used memory:    320 kB
Autostart:      disable

6. # service libvirtd restart
Stopping libvirtd daemon:                                  [  OK  ]
Starting libvirtd daemon:                                  [  O

7. # virsh list --all
 Id Name                 State
----------------------------------
4584 vm1                  running
  - fedora-rawhide       shut off

[root@dhcp-66-70-184 Downloads]# virsh dominfo vm1
Id:             4584
Name:           vm1
UUID:           c53ea2c3-8291-b6e0-ee4f-329ef23944b2
OS Type:        exe
State:          running
CPU(s):         1
CPU time:       0.0s
Max memory:     500000 kB
Used memory:    320 kB
Autostart:      disable

  
Actual results:
After restart libvirtd service, the guest is stilling running. (The same behavior like when 'autostart' is enabled)

Expected results:
After restart libvirtd service, the guest should be shut off as the 'autostart' is disabled

Additional info:
When the 'autostart' is enabled, after restart libvirtd service, the guest is running status. This is expected result.
Comment 2 RHEL Product and Program Management 2010-05-07 03:56:11 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Ryota Ozaki 2010-08-05 07:38:52 EDT
(In reply to comment #0)
> Description of problem:
> Disable the 'autostart' for a running guest, it seems take effect when checking
> dominfo. But after restart libvirtd service, the guest is stilling running as
> 'autostart' is enabled.
> 
(snip)
> 
> Actual results:
> After restart libvirtd service, the guest is stilling running. (The same
> behavior like when 'autostart' is enabled)
> 
> Expected results:
> After restart libvirtd service, the guest should be shut off as the 'autostart'
> is disabled

This is NOTABUG because 'autostart' doesn't guarantee anything about shutdown of domains. The result is expected as the API definition.

> 
> Additional info:
> When the 'autostart' is enabled, after restart libvirtd service, the guest is
> running status. This is expected result.
Comment 5 Daniel Veillard 2010-10-11 11:19:11 EDT
As comment #4 rightly pointed out, when libvirtd stops it doesn't stop the
guests so in this scenario the behaviour is just fine,

Daniel

Note You need to log in before you can comment on or make changes to this bug.