Bug 589882 - virt-install command with option --extra-args fail during install vm
virt-install command with option --extra-args fail during install vm
Status: CLOSED DUPLICATE of bug 586175
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 03:53 EDT by Wayne Sun
Modified: 2010-05-07 10:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 10:08:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Sun 2010-05-07 03:53:36 EDT
Description of problem:
Fail to install vm by option: --extra-args "console=ttyS0,115200".
The xml file is established and with no problem. The domain installation still in progress, but when try to connect to it by vnc-viewer, an error occour: Cannot determine the VNC port for the guest rhel5_0320pm. 

Version-Release number of selected component (if applicable):
python-virtinst-0.500.3-1.el6.noarch
libvirt-0.8.1-1.el6.x86_64
qemu-kvm-0.12.1.2-2.50.el6.x86_64

How reproducible:
always


Steps to Reproduce:
# virt-install -n rhel5_0320pm -r 1000 -f /var/lib/libvirt/images/rhel5_0320pm.img -s 5 -l http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-5-Server/U4/i386/os/  --nographics --extra-args "console=ttyS0,115200"


Starting install...
Retrieving file .treeinfo...                                                                                                          |  874 B     00:00 ... 
Retrieving file vmlinuz...                                                                                                            | 3.5 MB     00:00 ... 
Retrieving file initrd.img...                                                                                                         |  13 MB     00:00 ... 
Creating domain...                                                                                                                    |    0 B     00:00     
error: Failed to get local hostname

Domain installation still in progress. You can reconnect to 
the console to complete the installation process.

  
Actual results:
Failed to install vm.

Expected results:
Install succesfully.

Additional info:
Comment 2 RHEL Product and Program Management 2010-05-07 05:04:55 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Cole Robinson 2010-05-07 10:08:25 EDT

*** This bug has been marked as a duplicate of bug 586175 ***

Note You need to log in before you can comment on or make changes to this bug.