Bug 589906 - Default monospace font characters are overlapping in gnome-terminal
Summary: Default monospace font characters are overlapping in gnome-terminal
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: smc-fonts   
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
low
Target Milestone: rc
: ---
Assignee: Pravin Satpute
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 09:16 UTC by Praveen Arimbrathodiyil
Modified: 2013-06-17 04:07 UTC (History)
10 users (show)

Fixed In Version: smc-fonts-04.2-9.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:38:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
overlapping with monospace font (32.71 KB, image/png)
2010-05-07 09:16 UTC, Praveen Arimbrathodiyil
no flags Details
screenshot (284.54 KB, image/png)
2010-05-07 19:06 UTC, James G. Brown III
no flags Details
gnome terminal with Dejavu Sans Mono manually selected (282.74 KB, image/png)
2010-05-08 07:34 UTC, Praveen Arimbrathodiyil
no flags Details
currently Default behaviour of Terminal (22.10 KB, image/png)
2010-09-06 05:03 UTC, A S Alam
no flags Details

Description Praveen Arimbrathodiyil 2010-05-07 09:16:53 UTC
Created attachment 412272 [details]
overlapping with monospace font

Description of problem:
Default monospace font characters are overlapping in gnome-terminal. The problem goes away with Dejavu-Sans-Mono.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1.Select any indic locale
2.open gnome-terminal
3.observer shell prompt
  
Actual results:
character next to @ is overlapped with @.

Expected results:

no overlapping
Additional info:

Comment 2 RHEL Product and Program Management 2010-05-07 11:31:39 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Bill Nottingham 2010-05-07 17:42:33 UTC
What *is* your default monospace font? It's supposed to be dejavu-sans-mono, AFAIK.

Comment 5 James G. Brown III 2010-05-07 19:06:13 UTC
Created attachment 412427 [details]
screenshot

Bill, System > Appearance > Font says:

Monospace 10 

gnome-terminal has the default "Used the system fixed width font" checked

Choosing DejaVu Sans and using any of those fonts does not fix this for me.

# rpm -qa | grep dejavu
dejavu-fonts-common-2.30-2.el6.noarch
dejavu-sans-fonts-2.30-2.el6.noarch

screenshot attached

- James

Comment 6 Bill Nottingham 2010-05-07 20:16:08 UTC
James: that implies you don't have the proper monospace font installed. dejavu-sans-mono-fonts would be required. It's installed as part of the fonts group.

Comment 7 Praveen Arimbrathodiyil 2010-05-08 07:26:13 UTC
(In reply to comment #4)
> What *is* your default monospace font? It's supposed to be dejavu-sans-mono,
> AFAIK.    

No, it is not. When I manually select Dejavu Sans Mono, this problem goes away.

Comment 8 Praveen Arimbrathodiyil 2010-05-08 07:34:13 UTC
Created attachment 412497 [details]
gnome terminal with Dejavu Sans Mono manually selected

Comment 9 James G. Brown III 2010-05-08 21:59:34 UTC
Bill, Ok. I suppose the reason I tacked onto this report was because I did a next->next->next install and didn't have dejavu-sans-mono-fonts installed and as such had a font issue...

I'll try a fresh nightly install to make sure this is still the case. 

- James

Comment 10 Kai Meyer 2010-05-27 14:39:57 UTC
I also did a "next->next->next" install of RHEL6, and also have the same issues. dejavu-sans-mono-fonts package includes a font that does not have the same overlap issues.

# rpm -qa | grep font | sort
dejavu-fonts-common-2.30-2.el6.noarch
dejavu-sans-fonts-2.30-2.el6.noarch
dejavu-sans-mono-fonts-2.30-2.el6.noarch
fontconfig-2.8.0-1.el6.x86_64
fontpackages-filesystem-1.41-1.1.el6.noarch
libfontenc-1.0.5-2.el6.x86_64
libXfont-1.4.1-1.el6.x86_64
xorg-x11-fonts-misc-7.2-9.1.el6.noarch
xorg-x11-font-utils-7.2-10.el6.x86_64

Comment 11 Behdad Esfahbod 2010-05-27 18:58:00 UTC
What's the output of "fc-match Monospace"?

Comment 12 Praveen Arimbrathodiyil 2010-05-28 08:39:46 UTC
[pravi@savannah-test ~]$ fc-match "Monospace"
Meera_04.ttf: "Meera" "Regular"
[pravi@savannah-test ~]$ LANG=en_IN fc-match "Monospace"
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
[pravi@savannah-test ~]$ 

Dejavu Sans Mono is currently set as default Monospace font only for en* locales.
So I would like to have it as default Monospace font for Malayalam, and possibly other Indic languages as well.

Comment 13 Behdad Esfahbod 2010-05-28 21:22:11 UTC
If a font package claims installs itself as the default font for monospace and it's NOT monospace, not my fault really...

Comment 14 Praveen Arimbrathodiyil 2010-05-31 10:15:51 UTC
pravi@savannah:~$ rpm -ql smc-meera-fonts 
/etc/fonts/conf.d/66-smc-meera.conf
/etc/fonts/conf.d/90-smc-meera.conf
/usr/share/fontconfig/conf.avail/66-smc-meera.conf
/usr/share/fontconfig/conf.avail/90-smc-meera.conf
/usr/share/fonts/smc
/usr/share/fonts/smc/Meera_04.ttf
pravi@savannah:~$ cat /etc/fonts/conf.d/66-smc-meera.conf
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<match>
  <test name="lang">
    <string>ml-in</string>
  </test>
  <test name="family">
    <string>sans-serif</string>
  </test>
  <edit name="family" mode="prepend">
    <string>Meera</string>
  </edit>
</match>
<alias>
  <family>Meera</family>
  <default>
    <family>sans-serif</family>
  </default>
</alias>        
</fontconfig>

Meera font claims it is only a sans-serif font, not a monospace font. So fault is not with the font also. Could it be an issue with fontconfig falling back to default font when it does not get a Monospace font for a language?

Comment 15 Akira TAGOH 2010-06-01 04:50:22 UTC
I'm not testing at all since I don't have any environments to confirm right now, but according to all of the information the above, I guess getting rid of "<family>Meera<?family>" for _monospace_ in 65-nonlatin.conf may fixes this issue.

Now we have the certain fontconfig config files. I'd suggest to drop 65-nonlatin.conf to avoid the unexpected behaviour.

Comment 16 Akira TAGOH 2010-06-01 08:58:28 UTC
false alarm. ignore my comment #15. actually it didn't help. fontconfig seems picking up Meera to satisfy the requirements anyway since Meera is only the font available on RHEL6 for Malayalam.

So my suggestion to get this fixed in a timely manner then is:

a) drop latin glyphs from Meera font
b) add DejaVu Sans Mono as the strong binding prior to Meera for Malayalam
c) add another Malayalam fonts not problematic for monospace if there are.

BTW b) gives us similar issue to Bug#589974.

Comment 17 Praveen Arimbrathodiyil 2010-06-01 13:57:34 UTC
Some of the Indian language fonts (like Lohit) does not contain latin glyphs, so it fall back to latin fonts. Can it be done for Monospace too?

If a language does not have a monospace font can it fall back to Dejavu Sans Mono (for latin glyphs)?

Comment 18 Akira TAGOH 2010-06-02 09:23:30 UTC
(In reply to comment #17)
> Some of the Indian language fonts (like Lohit) does not contain latin glyphs,
> so it fall back to latin fonts. Can it be done for Monospace too?

If we drop the latin glyphs from Meera, yes. and that's a) idea.

> If a language does not have a monospace font can it fall back to Dejavu Sans
> Mono (for latin glyphs)?    

AFAICS no; at least on current implementation. this may be because trying to obtain the real font name with the language but not glyphs one requires. and may be hard to figure out all of requirements when requesting.

Comment 19 Pravin Satpute 2010-06-17 09:34:47 UTC
(In reply to comment #15)
> I'm not testing at all since I don't have any environments to confirm right
> now, but according to all of the information the above, I guess getting rid of
> "<family>Meera<?family>" for _monospace_ in 65-nonlatin.conf may fixes this
> issue.

if i follow this step, it is taking Lohit Malayalam font for monospace
malayalam, and it is solving mentioned problem

Comment 20 Pravin Satpute 2010-06-17 11:38:44 UTC
in other words setting Lohit Malayalam as a defualt for monospace solves the problem

Comment 21 Pravin Satpute 2010-06-28 08:43:32 UTC
added strong binding for Dejavu Sans Mono
fixed in smc-fonts-04.2-9.el6

Comment 23 A S Alam 2010-09-06 05:03:01 UTC
Created attachment 443228 [details]
currently Default behaviour of Terminal

Comment 24 A S Alam 2010-09-06 05:03:41 UTC
tested package: smc-kalyani-fonts-04.2-11.el6.noarch

Comment 25 releng-rhel@redhat.com 2010-11-10 21:38:01 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.