Bug 589907 - Display blanks when modesetting on Intel chipsets
Summary: Display blanks when modesetting on Intel chipsets
Status: CLOSED DUPLICATE of bug 587171
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 09:20 UTC by Jonathan Dieter
Modified: 2010-05-07 12:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 12:24:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (26.12 KB, text/plain)
2010-05-07 09:20 UTC, Jonathan Dieter
no flags Details
lspci -n output (750 bytes, text/plain)
2010-05-07 09:21 UTC, Jonathan Dieter
no flags Details
dmesg output (36.59 KB, text/plain)
2010-05-07 09:23 UTC, Jonathan Dieter
no flags Details
lspci -n output from second type of intel motherboard (561 bytes, text/plain)
2010-05-07 09:54 UTC, Jonathan Dieter
no flags Details
lspci -n output from third type of intel motherboard (684 bytes, text/plain)
2010-05-07 09:56 UTC, Jonathan Dieter
no flags Details
Xorg log from working motherboard type (26.38 KB, text/plain)
2010-05-07 10:00 UTC, Jonathan Dieter
no flags Details
lspci -n output from working motherboard type (561 bytes, text/plain)
2010-05-07 10:00 UTC, Jonathan Dieter
no flags Details
dmesg output from working motherboard type (31.12 KB, text/plain)
2010-05-07 10:03 UTC, Jonathan Dieter
no flags Details

Description Jonathan Dieter 2010-05-07 09:20:41 UTC
Created attachment 412273 [details]
Xorg log

Description of problem:
When I try to install Fedora 13 (over PXE, local mirror updated today) onto a desktop with an Intel chipset, the display goes blank with a "Input out of range" error coming from the monitor.  I can SSH into the computer, but the only way to continue the install is using VNC.

As I can see the first second or so of the kernel loading, I believe the problem occurs when the modesetting happens.  Changing the monitor didn't fix the problem.

Version-Release number of selected component (if applicable):
2.6.33.3-79.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start PXE install
  
Actual results:
Blank monitor with "Input out of range" message

Expected results:
Fedora install screen

Comment 1 Jonathan Dieter 2010-05-07 09:21:46 UTC
Created attachment 412275 [details]
lspci -n output

Comment 2 Jonathan Dieter 2010-05-07 09:23:27 UTC
Created attachment 412276 [details]
dmesg output

Comment 3 Jonathan Dieter 2010-05-07 09:53:53 UTC
I've just finished installing the system over VNC, and the bug persists when the system is booted normally, so it's not just an installation problem.  I've swapped in another monitor that's the same resolution as the previous one (1280x1024), but the display stays blank, even if I kill and restart X.

We have several other motherboards with similar hardware, and two out of three have the blank screen.

Comment 4 Jonathan Dieter 2010-05-07 09:54:43 UTC
Created attachment 412282 [details]
lspci -n output from second type of intel motherboard

Comment 5 Jonathan Dieter 2010-05-07 09:56:39 UTC
Created attachment 412283 [details]
lspci -n output from third type of intel motherboard

Comment 6 Jonathan Dieter 2010-05-07 10:00:03 UTC
Created attachment 412286 [details]
Xorg log from working motherboard type

Comment 7 Jonathan Dieter 2010-05-07 10:00:53 UTC
Created attachment 412287 [details]
lspci -n output from working motherboard type

Comment 8 Jonathan Dieter 2010-05-07 10:03:08 UTC
Created attachment 412288 [details]
dmesg output from working motherboard type

Comment 9 Jonathan Dieter 2010-05-07 12:24:43 UTC

*** This bug has been marked as a duplicate of bug 587171 ***


Note You need to log in before you can comment on or make changes to this bug.