Bug 589924 - bad dwarf cfi data in qpid-cpp binary
Summary: bad dwarf cfi data in qpid-cpp binary
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qpid-cpp   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Kim van der Riet
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 10:11 UTC by Mark Wielaard
Modified: 2010-07-02 20:53 UTC (History)
2 users (show)

Fixed In Version: qpid-cpp-0.7.946106-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 20:53:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
python script to check for bad cfi in a binary (1.76 KB, text/plain)
2010-05-07 10:29 UTC, Mark Wielaard
no flags Details

Description Mark Wielaard 2010-05-07 10:11:12 UTC
Description of problem:

An old version of gcc generated bad dwarf cfi expressions. This would not impact the functioning of the package itself, but might make debugging the binary with gdb, or tracing with systemtap less practical. This isn't a very high priority. But if the package can be rebuild with a current toolchain, gcc-4.4.3-19.el6 or later, that would solve this issue. Background information: http://gcc.gnu.org/ml/gcc-patches/2010-04/msg01422.html This only affects a very small number of packages (and only the i686 binaries).

Version-Release number of selected component (if applicable):

qpid-cpp-server-0.7.935473-1.el6.i686 (/usr/sbin/qpidd)

The attached check_cfi.py script (thanks to Petr Machata) can be used to check the output of readelf --debug-dump=frames to see whether the faulty dwarf cfi expressions are present in the binary. There should be no output, currently the output is:

readelf --debug-dump=frames /usr/sbin/qpidd | tail -n +3 | python check_cfi.py
['00000000', '0000001c', '00000000', 'CIE']
   DW_CFA_def_cfa: r4 (esp) ofs 4
   DW_CFA_offset: r8 (eip) at cfa-4
   DW_CFA_nop
   DW_CFA_nop
['000002a8', '00000048', '000002ac', 'FDE', 'cie=00000000', 'pc=08050b40..0805192e']
   DW_CFA_advance_loc: 4 to 08050b44
>  DW_CFA_def_cfa: r1 (ecx) ofs 0
   DW_CFA_advance_loc: 9 to 08050b4d
   DW_CFA_expression: r5 (ebp) (DW_OP_breg5: 0)
   DW_CFA_advance_loc: 10 to 08050b57
>  DW_CFA_def_cfa_expression (DW_OP_breg5: -16; DW_OP_deref)
   DW_CFA_advance_loc: 33 to 08050b78
   DW_CFA_expression: r3 (ebx) (DW_OP_breg5: -12)
   DW_CFA_expression: r6 (esi) (DW_OP_breg5: -8)
   DW_CFA_expression: r7 (edi) (DW_OP_breg5: -4)
   DW_CFA_advance_loc2: 1554 to 0805118a
   DW_CFA_remember_state
>  DW_CFA_def_cfa_register: r1 (ecx)
   DW_CFA_advance_loc: 1 to 0805118b
   DW_CFA_restore: r3 (ebx)
   DW_CFA_advance_loc: 1 to 0805118c
   DW_CFA_restore: r6 (esi)
   DW_CFA_advance_loc: 1 to 0805118d
   DW_CFA_restore: r7 (edi)
   DW_CFA_advance_loc: 1 to 0805118e
   DW_CFA_restore: r5 (ebp)
   DW_CFA_advance_loc: 3 to 08051191
   DW_CFA_def_cfa: r4 (esp) ofs 4
   DW_CFA_advance_loc: 1 to 08051192
   DW_CFA_restore_state
   DW_CFA_nop
   DW_CFA_nop
   DW_CFA_nop
error in instr #16, DW_CFA_def_cfa_register

Comment 2 Mark Wielaard 2010-05-07 10:29:18 UTC
Created attachment 412298 [details]
python script to check for bad cfi in a binary

Comment 3 Kim van der Riet 2010-05-07 11:10:45 UTC
Since these packages were built in Brew, what is the procedure for persuading Brew to use the newer (or current from a RHEL-6 perspective) toolchain?

Comment 4 RHEL Product and Program Management 2010-05-07 11:31:06 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Kim van der Riet 2010-05-19 19:13:21 UTC
A spot check of the latest build (qpid-cpp-0.7.946106-1) /usr/sbin/qpidd shows that this issue is fixed (as expected) by using updated tools in brew. I have not checked all binaries.

Comment 6 Mark Wielaard 2010-05-19 19:19:00 UTC
(In reply to comment #5)
> A spot check of the latest build (qpid-cpp-0.7.946106-1) /usr/sbin/qpidd shows
> that this issue is fixed (as expected) by using updated tools in brew. I have
> not checked all binaries.    

The issue was originally found only in that one binary, and not in any others, so this should now be fine. Thanks.

Comment 9 releng-rhel@redhat.com 2010-07-02 20:53:39 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.