Bug 589933 - Guest r3u9-32 could not get network after migration
Guest r3u9-32 could not get network after migration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 06:37 EDT by Golita Yue
Modified: 2013-01-09 17:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 06:54:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Golita Yue 2010-05-07 06:37:25 EDT
Description of problem:
start guest r3u9-32 and it can get network(passed for ping www.yahoo.com)
but it could not get network after migration. failed for 'ping www.yahoo.com' and 'service network restart'

Version-Release number of selected component (if applicable):
Host:
kernel  2.6.32-23.el6.x86_64
qemu-kvm-0.12.1.2-2.48.el6.x86_64

guest:
kernel 2.4.21-63.EL

How reproducible:
5/5

Steps to Reproduce:
1. start guest
/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -startdate now -cpu qemu64,+sse2 -drive file=/opt/r3u9_32.raw,if=ide,boot=on -net nic,model=rtl8139,macaddr=20:20:11:28:28:08,vlan=0 -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -vnc :3 -m 2G -smp 1 -balloon none -boot c -monitor stdio -uuid `uuidgen` -no-kvm-pit-reinjection -name r3u9-32
2. start listening mode
/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -startdate now -cpu qemu64,+sse2 -drive file=/opt/r3u9_32.raw,if=ide,boot=on -net nic,model=rtl8139,macaddr=20:20:11:28:28:08,vlan=0 -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -vnc :6 -m 2G -smp 1 -balloon none -boot c -monitor stdio -uuid `uuidgen` -no-kvm-pit-reinjection -name r3u9-32 -incoming tcp:0:5815
3. run migration
(qemu) migrate -d tcp:0:5815
4. check the network on guest
  
Actual results:
guest cannot get network

Expected results:
guest get network

Additional info:
Comment 2 RHEL Product and Program Management 2010-05-07 08:58:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Golita Yue 2010-06-29 06:54:21 EDT
Tested again in kernel 2.6.32-37.el6.x86_64 and qemu-kvm-0.12.1.2-2.82.el6.x86_64 (host intel & AMD).
Cannot reproduce this bug.
So closed this bug.

Note You need to log in before you can comment on or make changes to this bug.