Bug 589949 - virt-manager: rhel6 guest, 'shutdown' command doesn't work
virt-manager: rhel6 guest, 'shutdown' command doesn't work
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 07:23 EDT by Jianjiao Sun
Modified: 2010-06-06 21:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-06 21:12:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianjiao Sun 2010-05-07 07:23:25 EDT
Description of problem:
I have Install rhel6 snapshot-2 ,when I click buttion on the menu or toolbar,I can't shut down and reboot it.
But The fedora 12 can be shut down.

Version-Release number of selected component (if applicable):
[unanao@dhcp-65-37 ~]$ cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.0 Beta (Santiago) 

[unanao@dhcp-65-37 ~]$ rpm -qa |grep libvirt
libvirt-python-0.8.0-4.el6.x86_64
libvirt-client-0.8.0-4.el6.x86_64
libvirt-0.8.0-4.el6.x86_64

[unanao@dhcp-65-37 ~]$ rpm -q virt-manager
virt-manager-0.8.4-1.el6.noarch


How reproducible:
always

Steps to Reproduce:
I have installed guest(rhel6).
   1. Click Application->System tools->Virtual Machine Manager.
   2. Click Open button at the bottom of Virtual Machine Manager window.
   3. Click Virtual Machine->Run.
   4. Click Virtual Machine->Shut Down->Shut Down(or reboot) after VM is boot.


  
Actual results:
There is no effect when I click the buttion.

Expected results:
When I click the buttion ,system will halt or reboot as the buttion spcified.

Additional info:
My system is only for virt-manager,it is cleaned.
Comment 2 RHEL Product and Program Management 2010-05-07 08:58:46 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Chris Lalancette 2010-05-07 11:33:51 EDT
Is the GNOME desktop, or acpid running inside the guest?  Without one of those two there is no application to react to the shutdown event, so it won't work.

Chris Lalancette
Comment 4 Cole Robinson 2010-05-11 13:42:04 EDT
Also, does 'virsh shutdown $vmname' have any different effect?
Comment 5 Justin Clift 2010-05-29 06:52:49 EDT
This may be related to BZ #594596.

  https://bugzilla.redhat.com/show_bug.cgi?id=594596

If the vm was installed with a "Minimal" installation set, then acpid won't have been installed, causing this behaviour.
Comment 6 Jianjiao Sun 2010-06-06 21:12:43 EDT
Thanks for your kindly reply!
I have test a "full" install,I test the rhel5.4 ,rhel5.5,rhel6 and windows2003,And verified they all work well.
Because I have change the machine some days ago,can't find the environment again.
But the problem had been solved.Therefore this bug can be closed.I will install "minimal"install test BZ #594596 again.
 
Sorry,I reply so late.Because after I report the bug ,and back to school for a few days , after I returned,other things surrouned it.

Note You need to log in before you can comment on or make changes to this bug.