Bug 589963 - Time jump backwards in Guest r3u9-32
Time jump backwards in Guest r3u9-32
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Zachary Amsden
Virtualization Bugs
:
Depends On:
Blocks: 528898
  Show dependency treegraph
 
Reported: 2010-05-07 08:15 EDT by Golita Yue
Modified: 2013-01-10 21:58 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 570824
Environment:
Last Closed: 2010-06-07 20:16:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
clock test (596 bytes, text/x-csrc)
2010-05-07 08:20 EDT, Golita Yue
no flags Details
result of r3u9-32 (11.75 KB, text/plain)
2010-05-07 08:21 EDT, Golita Yue
no flags Details

  None (edit)
Comment 1 Golita Yue 2010-05-07 08:20:29 EDT
Created attachment 412325 [details]
clock test
Comment 2 Golita Yue 2010-05-07 08:21:36 EDT
Created attachment 412326 [details]
result of r3u9-32
Comment 4 RHEL Product and Program Management 2010-05-07 10:08:15 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Dor Laor 2010-05-09 07:28:19 EDT
Please provide the qemu cmdline parameters and kvm/kernel versions.
Note that in 3.9 there is no pvclock, it's probably only the PIT.
Comment 8 Dor Laor 2010-05-11 04:12:21 EDT
Do you run anything special in the guest? NTP? Do any action like migration?
I find it pretty weird that the time goes backward for standard run.
Comment 10 Zachary Amsden 2010-05-11 18:59:55 EDT
Well, my 3.9 guest was using HPET, but that wasn't RHEL5.  Since you're disabling HPET in the command line, the guest should probably end up using the dreaded TSC.

Can you strip -no-hpet from the options?  I'm not sure if we officially support HPET for RHEL5, but the choice here is either fix the TSC or support the HPET.
Comment 11 Dor Laor 2010-05-11 19:21:05 EDT
hpet is not supported, I thought rhel3 uses the PIT, better add notsc cmdline to it
Comment 13 Zachary Amsden 2010-05-12 01:31:39 EDT
So that's PIT timer jumping backwards?  Yikes.
Comment 14 Zachary Amsden 2010-05-12 01:34:32 EDT
Actually, can you post results from:

dmesg | grep -i time

It would be nice to confirm the PIT is really being used.  Very strange the jiffies clock would cause backwards time or be any different on SMP.

Are you sure there is no ntpd / ntpdate running?
Comment 15 Zachary Amsden 2010-06-07 20:16:01 EDT
This bug is too confused to really make sense of.  There are multiple guests running different versions of RHEL mentioned.  I'm hopefully that Glauber's fixes and fixes to the various tick compensation mechanisms have already successfully resolved this bug.  In any case, local testing hasn't shown unstable time in r3u9 guests - and if it's TSC compensation which is causing the problem, there is already another open bug for that which is assigned to me.

Note You need to log in before you can comment on or make changes to this bug.