Bug 58998 - using rhn_package_manager to clear a channel's contents
Summary: using rhn_package_manager to clear a channel's contents
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels   
(Show other bugs)
Version: RHN Stable
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-29 00:53 UTC by Isaiah Weiner
Modified: 2007-04-18 16:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-15 16:11:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Isaiah Weiner 2002-01-29 00:53:41 UTC
Description of problem:
upon removing packages in /var/up2date/packages/<channel> i'm not sure how to 
make the web interface realize the files are gone. it would be nice if there 
were an option to rhn_package_manager to clear a channel's contents.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run rhn_package_manager
2. realize you goofed

Additional info:

Comment 1 Mihai Ibanescu 2002-01-29 01:13:19 UTC
This can be implemented either in rhn_package_manager or in the future channel 
editor (or in both). I can certainly add code to rhn_package_manager to unlink 
a package from a channel, but specifying the package on the command line is 
tricky (no, rpm filenames are not enough, there's an epoch too). That's why 
I'd rather go for a UI instead of a command line version. 


Comment 2 Isaiah Weiner 2002-01-29 01:18:01 UTC
I don't care which; which is faster, and what's the timeline on implementation?

Comment 3 Mihai Ibanescu 2002-01-29 01:26:37 UTC
The channel editor is in our roadmap. I'll check with the team.


Comment 4 Mihai Ibanescu 2002-05-01 16:34:03 UTC
The channel editor should accomplish this now, is that correct?

Comment 5 Isaiah Weiner 2002-05-01 16:41:17 UTC
I have no such menu associated with org_id 1421245, user_id 377569.

Comment 6 Mihai Ibanescu 2002-05-01 17:36:10 UTC
I did the change in the database; if you don't see Channel Manager in the left
tab, then grant a Channel Admin role to the user you're using, and you should
start seeing it.

Comment 7 Isaiah Weiner 2002-05-01 17:50:17 UTC
Works!

Is there documentation somewhere about using the web interface to make a new 
errata?

Comment 8 Mihai Ibanescu 2002-05-01 18:10:29 UTC
rnorwood would be the best person to ask.

Comment 9 Josef Komenda 2002-05-15 19:49:36 UTC
Fixed on live, Closing.

Comment 10 Isaiah Weiner 2002-05-15 23:23:27 UTC
It already worked, I'm not sure what you fixed.

Is there documentation somewhere about using the web interface to make a new 
errata?  I'm not going to use direct email because I always get told to and no 
one ever responds. :-P

Comment 11 Josef Komenda 2002-05-16 12:03:48 UTC
Your comment on 2002-05-01 13:50:17 indicated that the bug had been resloved.
That is what my 'Fixed on live, Closing' comment referred to. Regarding
documentation for creating an Errata, I am not aware of any at this time. Please
feel free to open an RFE - adding a help entry for the 'make new errata' page.


Note You need to log in before you can comment on or make changes to this bug.