Bug 58999 - invalid server certificate
invalid server certificate
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-28 20:16 EST by Isaiah Weiner
Modified: 2015-01-07 18:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-12 14:35:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Isaiah Weiner 2002-01-28 20:16:44 EST
Description of problem:
A registered system executing `up2date clearcase-config` results in an error.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. execute `up2date clearcase-config`

Actual Results:  A dialog box popped up asking for confirmation of installation 
of the Red Hat, Inc. public key.  I clicked yes, and next, the dialog box 
closed and the terminal had an error on it.

[root@b2-lnx /root]# up2date clearcase-config          

Retrieving list of all available packages...
There was a fatal error communicating with the server.  The message was:

Error Class Code: 9
Error Class Info: Invalid Server Certificate.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

[root@b2-lnx /root]# 

Expected Results:  The clearcase-config package should've been downloaded from 
the proxy server and installed.

Additional info:

On the registered client machine, /etc/sysconfig/rhn/up2date points to the 
proxy server:

[root@b2-lnx /root]# grep -i serverurl /etc/sysconfig/rhn/up2date
useNoSSLForPackages[comment]=Use the noSSLServerURL for package, package list, g
noSSLServerURL[comment]=
noSSLServerURL=http://linus.cisco.com/XMLRPC
serverURL[comment]=Remote server URL
serverURL=http://linus.cisco.com/XMLRPC
[root@b2-lnx /root]#

Accessing the cisco-live channel through the web site does not produce a link 
for downloading the package.  This is probably a seperate problem.
Comment 1 Mihai Ibanescu 2002-01-28 20:21:01 EST
Did you register the machine recently? Remember you migrated from the beta 
environment to the live environment, the registration data didn't transfer.
Comment 2 Adrian Likins 2002-01-28 20:22:21 EST
sounds like the box isnt properly registered.

Where was the box registered?
Comment 3 Isaiah Weiner 2002-01-28 20:24:39 EST
The machine was registered over 20 times, using the proxy server, on Friday 
(after beta migration).
Comment 4 Mihai Ibanescu 2002-01-28 20:32:54 EST
Should I understand that #58839 has to be closed? I thought you're still 
trying to register the system, that bug is in NEEDINFO.
Comment 5 Isaiah Weiner 2002-03-12 14:35:17 EST
I suspect this can be closed.  But I can't see #58839 to be sure.
Comment 6 Josef Komenda 2002-03-20 12:23:52 EST
Bug 58839 has been closed, and a test of this bug shows no problems. Looks like
the system wasn't properly registered, (it was looking for a certificate on an
invalid server.) 

Closing. 

Joe K

Note You need to log in before you can comment on or make changes to this bug.