Bug 590000 - GFS2: invalid mount option leaves file system unmountable
GFS2: invalid mount option leaves file system unmountable
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: David Teigland
Cluster QE
: Regression
: 580940 (view as bug list)
Depends On:
Blocks: 559735
  Show dependency treegraph
 
Reported: 2010-05-07 09:37 EDT by Nate Straz
Modified: 2010-07-02 14:55 EDT (History)
10 users (show)

See Also:
Fixed In Version: cluster-3.0.12-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 14:55:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Straz 2010-05-07 09:37:05 EDT
Description of problem:

After trying an invalid mount option, other attempts to mount the file system hang.

Log messages from invalid mount option attempt:

May  6 13:32:06 tank-03 qarshd[10497]: Running cmdline: mount -t gfs2 -o garbage /dev/dm-5 /mnt/tank-cluster3
May  6 13:32:06 tank-03 kernel: GFS2: invalid mount option: garbage
May  6 13:32:06 tank-03 kernel: GFS2: can't parse mount arguments
May  6 13:32:06 tank-03 gfs_controld[9079]: do_leave: tank-cluster:tank-cluster3 not found

gfs_control ls output
 - tank-03, where invalid option was attempted
name          tank-cluster3
id            0x3bf37d95
flags         0x00000038 need_first,error,mounted
change        member 3 joined 1 remove 0 failed 0 seq 3,3
members       1 3 4

 - tank-01, first attempt after failure on tank-03
name          tank-cluster3
id            0x3bf37d95
flags         0x00000025 need_first,blocked,join
change        member 3 joined 1 remove 0 failed 0 seq 2,2
members       1 3 4

 - tank-04, second attempt
name          tank-cluster3
id            0x3bf37d95
flags         0x00000025 need_first,blocked,join
change        member 3 joined 1 remove 0 failed 0 seq 1,1
members       1 3 4


Version-Release number of selected component (if applicable):
cman-3.0.9-5.el6.i686
gfs2-utils-3.0.9-5.el6.i686
kernel-2.6.32-23.el6.i686

How reproducible:
Easily

Steps to Reproduce:
1. mount -o foo /dev/... /mnt/...
2. check for "gfs_controld do_leave: $cluster:$locktable not found" in /var/log/cluster/gfs_controld.log
  
Actual results:


Expected results:


Additional info:
Comment 2 Steve Whitehouse 2010-05-07 10:10:32 EDT
I think we might already have a bz open for this...
Comment 3 Steve Whitehouse 2010-05-07 10:13:28 EDT
It seems thats a RHEL5 bug, so I've added a dep.
Comment 4 David Teigland 2010-05-07 10:36:41 EDT
It's a simple bug, introduced by
http://git.fedorahosted.org/git/?p=cluster.git;a=commitdiff;h=46e0a2ef75abe03455b9e15f22bed2c53a839014

-void do_leave(char *table, int mnterr)
+void do_leave(char *name, int mnterr)

But the arg to the do_leave() call in process_connection wasn't changed.
Comment 6 Steve Whitehouse 2010-05-07 10:55:48 EDT
Thanks, looks good to me.
Comment 8 Nate Straz 2010-05-18 16:44:26 EDT
Verified against gfs2-utils-3.0.12-1.el6.i686.
Comment 9 Abhijith Das 2010-06-23 11:21:22 EDT
*** Bug 580940 has been marked as a duplicate of this bug. ***
Comment 10 releng-rhel@redhat.com 2010-07-02 14:55:02 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.