Bug 590016 - SELinux is preventing /usr/bin/gcm-apply "getattr" access on /var/run/cups/cups.sock.
SELinux is preventing /usr/bin/gcm-apply "getattr" access on /var/run/cu...
Status: CLOSED DUPLICATE of bug 588295
Product: Fedora
Classification: Fedora
Component: gnome-color-manager (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:7dd3ac1db52...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 10:16 EDT by Igor Katalnikov
Modified: 2010-05-07 13:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 13:53:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Katalnikov 2010-05-07 10:16:25 EDT
Summary:

SELinux is preventing /usr/bin/gcm-apply "getattr" access on
/var/run/cups/cups.sock.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gcm-apply. It is not expected that this
access is required by gcm-apply and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cupsd_var_run_t:s0
Target Objects                /var/run/cups/cups.sock [ sock_file ]
Source                        gcm-apply
Source Path                   /usr/bin/gcm-apply
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-color-manager-2.30.1-2.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-13.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.3-79.fc13.i686.PAE #1 SMP Mon
                              May 3 22:57:56 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Fri 07 May 2010 02:41:22 PM CEST
Last Seen                     Fri 07 May 2010 02:41:22 PM CEST
Local ID                      1408ef71-439d-4dfa-ac36-142c847a73e7
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273236082.522:7): avc:  denied  { getattr } for  pid=2109 comm="gcm-apply" path="/var/run/cups/cups.sock" dev=sda1 ino=1441832 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cupsd_var_run_t:s0 tclass=sock_file

node=(removed) type=SYSCALL msg=audit(1273236082.522:7): arch=40000003 syscall=195 success=yes exit=0 a0=713bdb a1=bf855f1c a2=a97ff4 a3=9a62c38 items=0 ppid=1 pid=2109 auid=4294967295 uid=42 gid=477 euid=42 suid=42 fsuid=42 egid=477 sgid=477 fsgid=477 tty=(none) ses=4294967295 comm="gcm-apply" exe="/usr/bin/gcm-apply" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gcm-apply,xdm_t,cupsd_var_run_t,sock_file,getattr
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t cupsd_var_run_t:sock_file getattr;
Comment 1 Daniel Walsh 2010-05-07 11:15:18 EDT
I believe this is fixed in updates-testing.
Comment 2 Richard Hughes 2010-05-07 13:53:25 EDT

*** This bug has been marked as a duplicate of bug 588295 ***

Note You need to log in before you can comment on or make changes to this bug.