Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 590025 - PackageKit is too slow
PackageKit is too slow
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: PackageKit (Show other bugs)
6.0
i686 Linux
low Severity low
: rc
: ---
Assigned To: Richard Hughes
desktop-bugs@redhat.com
:
Depends On: 579262
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 10:32 EDT by Lubos Kocman
Modified: 2010-11-10 14:32 EST (History)
7 users (show)

See Also:
Fixed In Version: PackageKit-0.5.8-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 579262
Environment:
Last Closed: 2010-11-10 14:32:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output strace -p `pkcon` -o strace.txt (677.24 KB, text/plain)
2010-05-07 11:04 EDT, Lubos Kocman
no flags Details

  None (edit)
Description Lubos Kocman 2010-05-07 10:32:56 EDT
Description of the problem:

After execution of pkcon details Mozilla I had to wait like for 5 minutes or even more to get following output:


lkocman@ThinkPad X60$ pkcon search details Mozilla
Searching by details          [=========================]         
Starting                      [=========================]         
Querying                      [=========================]         
Installed   	ca-certificates-2010.63-3.el6.noarch    	The Mozilla CA root certificate bundle
Installed   	firefox-3.6.3-4.el6.i686                	Mozilla Firefox Web browser
Installed   	mozilla-filesystem-1.9-5.1.el6.i686     	Mozilla filesytem layout
Installed   	nspluginwrapper-1.3.0-12.el6.i686       	A compatibility layer for Netscape 4 plugins
Installed   	thunderbird-3.0.4-1.el6.i686            	Mozilla Thunderbird mail/newsgroup client
Installed   	totem-mozplugin-2.28.5-5.el6.i686       	Mozilla plugin for Totem
Available   	bsf-2.4.0-4.1.el6.noarch                	Bean Scripting Framework
Available   	bsf-2.4.0-4.1.el6.noarch                	Bean Scripting Framework
Available   	firefox-3.6.4-1.el6.i686                	Mozilla Firefox Web browser
Available   	firefox-3.6.4-1.el6.i686                	Mozilla Firefox Web browser
Available   	ldapjdk-4.18-5.1.el6.i686               	The Mozilla LDAP Java SDK
Available   	ldapjdk-4.18-5.1.el6.i686               	The Mozilla LDAP Java SDK
Available   	mozldap-6.0.5-6.2.el6.i686              	Mozilla LDAP C SDK
Available   	mozldap-6.0.5-6.2.el6.i686              	Mozilla LDAP C SDK
Available   	mozldap-devel-6.0.5-6.2.el6.i686        	Development libraries and examples for Mozilla LDAP C SDK
Available   	mozldap-devel-6.0.5-6.2.el6.i686        	Development libraries and examples for Mozilla LDAP C SDK
Available   	perl-Mozilla-LDAP-1.5.2-6.2.el6.i686    	LDAP Perl module that wraps the Mozilla C SDK
Available   	perl-Mozilla-LDAP-1.5.2-6.2.el6.i686    	LDAP Perl module that wraps the Mozilla C SDK
Available   	thunderbird-3.0.4-2.el6.i686            	Mozilla Thunderbird mail/newsgroup client
Available   	thunderbird-3.0.4-2.el6.i686            	Mozilla Thunderbird mail/newsgroup client
Available   	totem-mozplugin-2.28.5-6.el6.i686       	Mozilla plugin for Totem
Available   	totem-mozplugin-2.28.5-6.el6.i686       	Mozilla plugin for Totem

I'm not able to reproduce this problem any more (to get output now takes less than 10s)

Could you please check if it can't be the same problem that was fixed by:

---
commit 95f29eab53e273f8b7824d878578ffe2e8770aba
Author: Richard Hughes <richard@hughsie.com>
Date:   Fri Mar 26 09:26:19 2010 +0000

    Ensure the Package(finished) signal is always sent during the transaction. Fixes #522628
---

Version:

RHEL 6.0 snapshot 2
lkocman@ThinkPad X60$ pkcon --version
0.5.8

PackageKit-yum-plugin-0.5.8-2.el6.i686
PackageKit-glib-0.5.8-2.el6.i686
PackageKit-gtk-module-0.5.8-2.el6.i686
PackageKit-0.5.8-2.el6.i686
PackageKit-gstreamer-plugin-0.5.8-2.el6.i686
PackageKit-yum-0.5.8-2.el6.i686
PackageKit-device-rebind-0.5.8-2.el6.i686



+++ This bug was initially created as a clone of Bug #579262 +++

Description of problem:
Since the last PackageKit's update, PackageKit is very too slow to update (5-30 for download the meta-data, 5 minutes for display the updates then changelogs), and for start the update…

No problem with the composant for installation.
But with YUM, I download my updates with 350 ko/s


Version-Release number of selected component (if applicable):
PackageKit 0.5.7-2.fc12 x86_64


Network connectivity was ok. But I'm not able to reproduce problem. Could you please check if 



How reproducible:
Launch update with PackageKit

--- Additional comment from rhughes@redhat.com on 2010-04-03 15:27:36 EDT ---

Could you provide more details please? Is this reproducible?

--- Additional comment from cacouret@wanadoo.fr on 2010-04-03 19:23:02 EDT ---

I have just to launch update with PackageKit to have this bug.
With my 2 machines, it's same.

More details ? The GNOME's sensors detect no network activity with my machines, but PackageKit say "Getting information" or "Download meta-data" and PackageKit not work correctly with it comportment…

--- Additional comment from rhughes@redhat.com on 2010-04-06 04:37:50 EDT ---

Is it as slow if you use "pkcon update" rather than the GNOME GUI tools?

--- Additional comment from cacouret@wanadoo.fr on 2010-04-06 11:31:41 EDT ---

After « pkcon update », GNOME GUI PackageKit is faster, even after « yum clean all ».

I do not know why ...

--- Additional comment from rhughes@redhat.com on 2010-04-06 11:55:34 EDT ---

I think this was fixed in PackageKit 0.6.3:

commit 95f29eab53e273f8b7824d878578ffe2e8770aba
Author: Richard Hughes <richard@hughsie.com>
Date:   Fri Mar 26 09:26:19 2010 +0000

    Ensure the Package(finished) signal is always sent during the transaction. Fixes #522628

:100644 100644 74b4924... 81751cd... M  src/pk-backend.c
Comment 1 Richard Hughes 2010-05-07 10:39:50 EDT
It's probably a good idea to backport 95f29eab53e273f8b7824d878578ffe2e8770aba into RHEL6, agreed.
Comment 2 Lubos Kocman 2010-05-07 11:03:29 EDT
Hello I succeeded to reproduce similar problem and I caught output by strace (strace -p `pgrep pkcon` (hope it will help) see strace.txt
Comment 3 Lubos Kocman 2010-05-07 11:04:42 EDT
Created attachment 412373 [details]
strace output strace -p `pkcon` -o strace.txt
Comment 4 Lubos Kocman 2010-05-07 11:07:36 EDT
strace.out was taken from the first pkcon update from the following output

lkocman@ThinkPad X60$ pkcon update
Updating system               [=========================]         
Waiting for authentication    [=========================]         
Starting                      [=========================]         
Running                       [=========================]         
Updating system               [=========================]         
Waiting for authentication    [=========================]         
Starting                      [=========================]         
Running                       [=========================]         
Resolving dependencies        [=========================]         
Downloading packages          [=========================]         
Testing changes               [=========================]         
Installing updates            [=========================]         
Installing packages           [=========================]         
Installing updates            [=========================]         
Installing packages           [=========================]         
Installing updates            [=========================]         
Installing packages           [=========================]         
Installing updates            [                         ] (0%)  ^C
lkocman@ThinkPad X60$ ls
output.txt
lkocman@ThinkPad X60$ mv output.txt strace.txt
lkocman@ThinkPad X60$ wc -l strace.txt 
9657 strace.txt
lkocman@ThinkPad X60$ vi strace.txt 
lkocman@ThinkPad X60$ ^C
lkocman@ThinkPad X60$ sudo pkcon update
Updating system               [=========================]         
Fatal error: Already performing system update
lkocman@ThinkPad X60$ sudo pkcon update
Updating system               [=========================]         
Fatal error: Already performing system update
lkocman@ThinkPad X60$ sudo pkcon update
Updating system               [=========================]         
Fatal error: Already performing system update
lkocman@ThinkPad X60$ sudo pkcon update
Updating system               [=========================]         
Fatal error: Already performing system update
lkocman@ThinkPad X60$ wc -l strace.txt ^C
lkocman@ThinkPad X60$ sudo pkcon update
Updating system               [=========================]         
Fatal error: Already performing system update
lkocman@ThinkPad X60$ sudo pkill pkcon
lkocman@ThinkPad X60$ sudo pkcon update
Updating system               [=========================]         
Waiting for authentication    [=========================]         
Starting                      [=========================]         
Running                       [=========================]         
The transaction failed: internal-error, Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 1496, in update_system
    # to avoid taking all the system's bandwidth.
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 3167, in update
    installed_pkg =  self.getInstalledPackageObject(installed)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2610, in getInstalledPackageObject
    raise Errors.RpmDBError, _('Package tuple $s could not be found in rpmdb') $ str(pkgtup)
RpmDBError: Package tuple ('bluecurve-cursor-theme', 'noarch', '0', '8.0.2', '6.el6') could not be found in rpmdb

lkocman@ThinkPad X60$ sudo pkcon update
Updating system               [=========================]         
Waiting for authentication    [=========================]         
Starting                      [=========================]         
Running                       [=========================]         
The transaction failed: no-packages-to-update, Nothing to do
lkocman@ThinkPad X60$ sudo pkcon update
Updating system               [=========================]         
Waiting for authentication    [=========================]         
Starting                      [=========================]         
The transaction failed: no-packages-to-update, Nothing to do
lkocman@ThinkPad X60$
Comment 5 RHEL Product and Program Management 2010-05-07 11:23:43 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Lubos Kocman 2010-07-15 06:57:48 EDT
Hello

I'm not facing this issue any more. I believe that It may be moved to verified as I did multiple actions via pkcon and no hangout appeared.

PackageKit-0.5.8-8.el6.x86_64
Comment 7 Lubos Kocman 2010-07-22 09:46:53 EDT
Verified on PackageKit-0.5.8-8.el6


Hello I haven't faced to this issue for a long time. So moving to verified.

Thank you guys
Comment 9 releng-rhel@redhat.com 2010-11-10 14:32:24 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.