Bug 590107 - RFE: add python3-bpython subpackage to the build
RFE: add python3-bpython subpackage to the build
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bpython (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Terje Røsten
Fedora Extras Quality Assurance
:
Depends On: 537244
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 14:17 EDT by Dave Malcolm
Modified: 2010-05-10 19:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 19:06:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to devel/bpython.spec to add python3 subpackage to the build (4.12 KB, patch)
2010-05-07 14:21 EDT, Dave Malcolm
no flags Details | Diff

  None (edit)
Description Dave Malcolm 2010-05-07 14:17:42 EDT
Recent bpython supports Python 3 and Python 2 from one tarball, with its setup.py invoking 2to3 within the build.

I'm attaching a patch which adds a python3 subpackage to the build, so that the bpython.src.rpm emits both bpython and python3-bpython rpms.

I've tried to follow the packaging guidelines here:
https://fedoraproject.org/wiki/Packaging:Python#Building_more_than_once

I've tested the results with a local build and I'm able to use the built python3-bpython executable, and it seems sane.

(I also added a FIXME about the "Requires: pyparsing"; is it really needed?  pyparsing supports python3 in recent builds, but I haven't yet built python3 rpms of it for Fedora, and it worked, and I can't see any reference to pyparsing in the most recent tarball).
Comment 1 Dave Malcolm 2010-05-07 14:21:17 EDT
Created attachment 412419 [details]
Patch to devel/bpython.spec to add python3 subpackage to the build
Comment 2 Terje Røsten 2010-05-07 17:37:28 EDT
Thanks, I wanted to have a look at this after Fedora 13 was released.

Now I can go faster, thanks!

Will python3 have a gtk stack? 

Upcoming bpython 0.9.7 will have a useful bpython-gtk mode.

Even one more question: I am struggling with some gq bugs. I have contacted
Sven, however more people is always good. I ask because I saw your name in the
gq ChangeLog. Could you have a look at [abrt] bugs in this list:

https://bugzilla.redhat.com/buglist.cgi?component=gq&product=Fedora

Thanks in advance.
Comment 3 Terje Røsten 2010-05-09 08:46:43 EDT
Imported and built for rawhide.

I will import into F-13 when python3-pygments is ready there.
Comment 4 Dave Malcolm 2010-05-10 14:25:21 EDT
(In reply to comment #2)
> Thanks, I wanted to have a look at this after Fedora 13 was released.
> 
> Now I can go faster, thanks!

Thanks for applying this.

I see that you removed the pyparsing dependency:
http://cvs.fedoraproject.org/viewvc/rpms/bpython/devel/bpython.spec?r1=1.13&r2=1.14


> Will python3 have a gtk stack? 
Eventually, but pygtk isn't fully ported yet, and PyGI isn't ready yet, alas.


> Upcoming bpython 0.9.7 will have a useful bpython-gtk mode.
That's good.  I think for now, the python 2 subpackage ought to have it, but the python 3 subpackage will have to skip it until we have pygtk for Python 3.  The UI probably ought to have a .desktop file, so that it appears in the menus.


> Even one more question: I am struggling with some gq bugs. I have contacted
> Sven, however more people is always good. I ask because I saw your name in the
> gq ChangeLog. Could you have a look at [abrt] bugs in this list:
> 
> https://bugzilla.redhat.com/buglist.cgi?component=gq&product=Fedora
I haven't looked at gq in years, so I'm not in a great position to address these.   It's been years since I worked with LDAP; IIRC "LAT" was a better tool, but unfortunately implemented in Mono, which I try to avoid.
Comment 5 Terje Røsten 2010-05-10 16:02:27 EDT
> I see that you removed the pyparsing dependency:
> http://cvs.fedoraproject.org/viewvc/rpms/bpython/devel/bpython.spec?r1=1.13&r2=1.14

Yes, removed the package and bpython was still happy.
 

> I think for now, the python 2 subpackage ought to have it, but
> the python 3 subpackage will have to skip it until we have pygtk for Python3  

Sound like a plan.

 
> I haven't looked at gq in years,

Problem is nobody did...


> "LAT" was a better tool, but unfortunately implemented in Mono

$ yum -y remove mono\*

I found Apache Directory Studio http://directory.apache.org/studio/ to be very impressive. However, it requires Maven 2.2 which did not make into Fedora 13:

 http://fedoraproject.org/wiki/MavenUpdate
Comment 6 Dave Malcolm 2010-05-10 19:06:37 EDT
Closing this bug since the python3-enabled bpython is in rawhide.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.