Bug 59012 - Complete system hang on PIII/i815 machine
Complete system hang on PIII/i815 machine
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
high Severity high
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-01-29 04:15 EST by whinson
Modified: 2008-08-01 12:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description whinson 2002-01-29 04:15:05 EST
Description of Problem:

After installing kernel 2.4.9-21, my system (PIII-866, i815 chipset, 
512M RAM, 40G HD, using chipset audio and video with no cards
installed other than additional Intel eepro100 Ethernet adapter) would
completely freeze after a period ranging from 2-30 minutes -- would
not respond to keyboard or mouse, unable to telnet or ssh in, was
totally wedged and unresponsive to anything other than a hard reboot.
Problem disappeared after backing out to kernel 2.4.9-13.

Version-Release number of selected component (if applicable):


How Reproducible:

Steps to Reproduce:
1. Install kernel 2.4.9-21
2. Reboot system.
3. Wait.

Actual Results:

System would hang completely, often within minutes, but sometimes ran
up to half an hour before hanging.

Expected Results:

Should have run normally.

Additional Information:

Checked logs, no warnings or errors.  System is a vanilla PIII/866,
i815 motherboard, 512M RAM, 40G Western Digital HD, generic 56X CD-ROM.
Am using the onboard video and audio; only additional card installed
is a second Intel eepro100 Ethernet card.  Will be happy to provide
any other details needed.
Comment 1 Konstantin 2002-02-01 11:22:45 EST
I have very similar machine (i815,PIII-933,TNT2Ultra-32Mb,built-in audio
(i810+Avance ALC200/200P),512Mb,i82557/i82558 10/100 Ethernet), RedHat 7.2
With 2.4.7-10 worked just fine. (I use KDE, machine works only at daytime and
is turned off at night.)
With 2.4.9-13 all worked good, but sound (see 54855,56781).
I didn't test 2.4.9-21 for stability, but I have easily reproducible (on my
machine) bug:
Bootup, runlevel 5, kdm login, KDE loaded, logoff, and here I have black
screen or console login prompt and system hang, at least, keyboard is
completely locked, I cannot switch on VC's or reboot with Ctrl-Alt-Del,
Ctrl-Alt-Backspace have no effect too.
The last messages in /var/log/messages:
Jan 31 13:15:44 cathost kde(pam_unix)[1070]: session closed for user cat
Jan 31 13:15:44 cathost kdm[943]: Server for display :0 terminated unexpectedly
XFree86.0.log have no error messages

I have errata partly applied (dependencies ok), glibc-2.2.4-19.3, XFree86 and
KDE aren't updated, versions from base ISO distribution.
Comment 2 Konstantin 2002-02-01 11:35:11 EST
Clarification: kernel-2.4.9-21.i686.rpm
Comment 3 Jirka Pech 2002-02-06 04:25:02 EST
I've encountered exactly the same problems on similar hardware configuration, but caused surely by i815 sound driver.

It's reproducible by installing kernel 2.4.9-21 and running mpg123 (or anything else) to play MP3. When MP3 song ends, player 
will normally exit, but in this case it will exit, but it hang's the whole system. Nothing but the hardware reboot will help.

I'm 90% sure than it's not problem of the player, but the kernel driver. When I switched back to older kernel, everything works 
Comment 4 Jason M. Sullivan 2002-02-11 15:15:20 EST
I have a similar machine (930MHz PIII, intel 815 chipset with built in audio). 
I had similar problems with 2.4.9-13 w.r.t. sound, and there was aslo a deadlock
that I needed to upgrade to 2.4.9-21 to cure.  When I upgraded and brought up
KDE, the system would hang after a minute or so.  I unloaded the sound driver
modules after I rebooted, and commented out the relevent lines (w.r.t. sound) in
moudles.conf.  Now when I bring up KDE I have no problems (it's been running ok
for about a half an hour).

This seems to implicate a bad sound driver.
Comment 5 Jirka Pech 2002-02-12 03:11:03 EST
Another issue in this case: When I'm exiting KDE, it plays 'exit sound' and 
system will hang completely. Only the mouse cursor stays on the black screen 
and it's time to hardware reboot.
Comment 6 Shawn D. Kelly 2002-06-23 14:27:00 EDT
I am having an issue with the i815e chipset as well.

I initally installed RH 7.3 and experienced KDE dropping back to the login
screen and GNOME going spastic - flashing the screen and popping up BUS and
application errors.  Neither of these issues were present when I had Mandrake
8.2 or Red Hat 7.2 installed.  So, I decided to go down to 7.2 since I couldn't
find a solution for 7.3.

Then, I ran into the same issue under 7.2 after using up2date.  I updated the
kernel to 2.4.7-34, X to 4.1.0-25, glibc to 2.2.4-24, and up2date and
up2date-gnome to their latest versions listed.

Since this started AFTER the updates, I deciced to do a clean install and start
testing.  I finally ended up at the culprit - kernel 2.4.7-34.  I know this to
be the culprit because I'm running right now typing this message while using all
of the other updates listed above with kernel 2.4.7-10, the base kernel for 7.2.

If I reboot my system and choose kernel 2.4.7-34, I will not be able to use X at

Comment 7 Bugzilla owner 2004-09-30 11:39:21 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.