Bug 590125 - RHEL 6 beta 1 install inside of KVM fails with kernel panic
RHEL 6 beta 1 install inside of KVM fails with kernel panic
Status: CLOSED DUPLICATE of bug 574621
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.6
x86_64 Linux
medium Severity medium
: beta
: ---
Assigned To: Marcelo Tosatti
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 15:06 EDT by Paul Batkowski
Modified: 2013-01-09 17:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 11:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console output showing the kernel boot and panic. (16.83 KB, application/octet-stream)
2010-05-07 15:06 EDT, Paul Batkowski
no flags Details
serial console of boot output from rhel 6 beta snap 1 (16.83 KB, text/plain)
2010-05-11 09:45 EDT, Paul Batkowski
no flags Details

  None (edit)
Description Paul Batkowski 2010-05-07 15:06:00 EDT
Created attachment 412426 [details]
serial console output showing the kernel boot and panic.

Description of problem:

When doing an initial boot of anaconda to start a RHEL 6 beta 1 install inside of KVM, the guest encounters a kernel panic early on which prevents installation of RHEL 6 beta 1.

Version-Release number of selected component (if applicable):

  Host (x86_64):
  - RHEL 5.5 + errata
  - kernel-2.6.18-194.3.1.el5
  - libvirt-0.6.3-33.el5
  - kvm-83-164.el5

  Guest (x86_64):
  - RHEL 6.0 beta 1
  - kernel-2.6.32-21.el6

How reproducible:

Every single boot attempt.

Steps to Reproduce:
1. Boot guest with 512MB of RAM (tried up to 2GB) using local iso file (RHEL6.0-20100420.n.0-Server-x86_64-DVD1.iso)
2. Select the first option in the bootloader: "Install or Upgrade an Existing System"
3. Watch the kernel boot up and fail.
  
Actual results:

Kernel boots and shortly after encounters an oops and a kernel panic, preventing the install.

Kernel panic - not syncing: Fatal exception
Pid: 1, comm: init Tainted: G      D    2.6.32-21.el6.x86_64 #1
Call Trace:
 [<ffffffff814c6284>] panic+0x78/0x137
 [<ffffffff814ca23c>] oops_end+0xdc/0xf0
 [<ffffffff81038543>] ? kvm_leave_lazy_mmu+0x63/0xa0
 [<ffffffff81042272>] no_context+0xf2/0x260
 [<ffffffff81038543>] ? kvm_leave_lazy_mmu+0x63/0xa0
 [<ffffffff81042505>] __bad_area_nosemaphore+0x125/0x1e0
 [<ffffffff8110dbe8>] ? __alloc_pages_nodemask+0xf8/0x6d0
 [<ffffffff810425d3>] bad_area_nosemaphore+0x13/0x20
 [<ffffffff814cbccf>] do_page_fault+0x2ef/0x3e0
 [<ffffffff81038543>] ? kvm_leave_lazy_mmu+0x63/0xa0
 [<ffffffff814c9595>] page_fault+0x25/0x30
 [<ffffffff81038543>] ? kvm_leave_lazy_mmu+0x63/0xa0
 [<ffffffff81136e8a>] move_page_tables+0x46a/0x610
 [<ffffffff8116ae68>] setup_arg_pages+0x188/0x330
 [<ffffffff811b4f4f>] load_elf_binary+0x4df/0x1b50
 [<ffffffff8112af47>] ? follow_page+0x2f7/0x410
 [<ffffffff8112af47>] ? follow_page+0x2f7/0x410
 [<ffffffff8112ff4f>] ? __get_user_pages+0x10f/0x420
 [<ffffffff811b236c>] ? load_misc_binary+0xac/0x3e0
 [<ffffffff8121720e>] ? ima_iint_find_get+0x2e/0x40
 [<ffffffff8116b63d>] search_binary_handler+0x11d/0x360
 [<ffffffff8116c875>] do_execve+0x245/0x320
 [<ffffffff8125780a>] ? strncpy_from_user+0x4a/0x90
 [<ffffffff8101159a>] sys_execve+0x4a/0x80
 [<ffffffff81014208>] kernel_execve+0x68/0xd0
 [<ffffffff8100a223>] ? run_init_process+0x23/0x30
 [<ffffffff8100a320>] init_post+0xf0/0x110
 [<ffffffff818bc875>] kernel_init+0x2a3/0x2ae
 [<ffffffff8101418a>] child_rip+0xa/0x20
 [<ffffffff818bc5d2>] ? kernel_init+0x0/0x2ae
 [<ffffffff81014180>] ? child_rip+0x0/0x20

Expected results:

Kernel does not panic.

Additional info:

See attachment for captured boot log.
Comment 2 RHEL Product and Program Management 2010-05-07 17:12:09 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Paul Batkowski 2010-05-11 09:45:44 EDT
Created attachment 413144 [details]
serial console of boot output from rhel 6 beta snap 1

Just tried with snap 1, which includes kernel-2.6.32-22.el6 and encountered the same issue which is preventing the install of RHEL 6 beta as a KVM guest running on a RHEL 5.5 host. Attaching capture of boot from serial console.
Comment 6 Amit Shah 2010-05-13 11:41:26 EDT
Can you test with 1G of guest RAM?
Comment 7 Paul Batkowski 2010-05-13 11:58:06 EDT
As originally posted, I already tried with up to 2GB for guest memory set and still this issue reproduces 100% of the time.
Comment 8 Marcelo Tosatti 2010-05-16 22:21:18 EDT
The patch on bz #574621 should fix this, marking as a duplicate.

I don't know whether that patch is already part of an official update, apparently not.

*** This bug has been marked as a duplicate of bug 574621 ***

Note You need to log in before you can comment on or make changes to this bug.