Bug 59013 - Sync not done properly through ssh
Summary: Sync not done properly through ssh
Status: CLOSED DUPLICATE of bug 58874
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rsync (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-29 10:04 UTC by Matthias Saou
Modified: 2014-03-17 02:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-29 11:50:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Saou 2002-01-29 10:04:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020109

Description of problem:
Upgrading the machine from which I synchronize files with rsync through ssh
resulted in file updates problems.

Version-Release number of selected component (if applicable):
2.4.6-8

How reproducible:
Always

Steps to Reproduce:
1. update to the latest rsync rsync-2.4.6-8 errata on the distant machine
2. run rsync -a -e ssh $* --delete --delete-after --exclude='nosync' \
        servername:/var/www/* \
        /var/www/

3. get the error message :-(
	

Actual Results:  Many error messages :
Warning: unexpected read size of 0 in map_ptr


Expected Results:  A correct synchronization of files.

Additional info:

This does not happen with rsync-2.4.6-5. Downgrading makes things work again.
Also, upgrading the "client" machines makes the sync still work fine.

Comment 1 Matthias Saou 2002-01-29 11:12:25 UTC
Ran from a client to a server both running rsync-2.4.6-8 :

receiving file list ... done
enigma/lbreakout2/
enigma/lbreakout2/lbreakout2-2.2-fr1.i386.rpm
Warning: unexpected read size of 0 in map_ptr
Warning: unexpected read size of 0 in map_ptr
1114516 (100%)
enigma/lbreakout2/lbreakout2-2.2-fr1.src.rpm
Warning: unexpected read size of 0 in map_ptr
Warning: unexpected read size of 0 in map_ptr
1154599 (100%)
enigma/lbreakout2/
wrote 19592 bytes  read 2251167 bytes  57487.57 bytes/sec
total size is 308556699  speedup is 135.88

After downgrading the server's rpm to rsync-2.4.6-5, it works fine but
re-downloads the files (they were probably corrupted after the first download!) :

receiving file list ... done
enigma/lbreakout2/lbreakout2-2.2-fr1.i386.rpm
1114516 (100%)
enigma/lbreakout2/lbreakout2-2.2-fr1.src.rpm
1154599 (100%)
enigma/lbreakout2/
wrote 38498 bytes  read 1131001 bytes  39644.03 bytes/sec
total size is 308556699  speedup is 263.84


Comment 2 adam.huffman 2002-01-29 11:40:58 UTC
I'm having similar problems running the updated rsync over ssh.
In one direction I get:

unexpected EOF in read_timeout

and the transfer fails.

In the other direction I get a segmentation fault and the transfer fails.

Comment 3 Bill Crawford 2002-01-29 11:50:50 UTC
FYI: this isn't only affecting SSH-based transfers.


Comment 4 Bill Nottingham 2002-01-29 15:42:00 UTC

*** This bug has been marked as a duplicate of 58874 ***


Note You need to log in before you can comment on or make changes to this bug.