Bug 590131 - Create Jira-->Bugzilla quick Reference Sheet, "how to"
Create Jira-->Bugzilla quick Reference Sheet, "how to"
Status: CLOSED WORKSFORME
Product: Bugzilla
Classification: Community
Component: Documentation (Show other bugs)
3.6
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Mike Harvey
Mike Harvey
:
Depends On:
Blocks: 585313
  Show dependency treegraph
 
Reported: 2010-05-07 15:34 EDT by Mike Harvey
Modified: 2013-06-23 23:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-08 09:06:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First shot (16.60 KB, application/vnd.oasis.opendocument.text)
2010-09-12 11:21 EDT, Lukáš Petrovický
no flags Details
Incremental improvements (17.83 KB, application/vnd.oasis.opendocument.text)
2010-09-13 04:46 EDT, Lukáš Petrovický
no flags Details

  None (edit)
Description Mike Harvey 2010-05-07 15:34:00 EDT
The idea is to leverage existing Bugzilla training for the entire Middleware team/users (don't reinvent the wheel) and for us (qe) to create a quick reference sheet, a how to in Jira mapped to a how to in Bugzilla.

Potential subject matter for Jira--> Bugzilla quick reference sheet:

- How to create a bug
- Required Fields/Field usage
- Field Mapping:  Jira--> Bugzilla
- State Mapping:  open, coding in progress, resolved, closed, reopened-->Bugzilla "states"
- Workflow/routing Mapping:  How bugs typically flow through the system. Maybe we can start with two pictures and see if they can be merged into one picture??
- permissions schemes, visibility
- dashboard
- Navigation Tips/Reporting tips (bugzilla shared queries)


Existing Bugzilla Training Resources to leverage:
ENG110 Bugzilla Process and Browser Interface This fundamental Red Hat Engineering course addresses Bugzilla, how it is used at Red Hat, the flow of a bug through the system, and usage of the web interface. Web based training course. http://rhu.gsslab.rdu.redhat.com/rhutc/ENG110.Bugzilla/syllabus.html  
ENG112 - Content Defintion Workflow.  Learn about the infamous three ACKS! This is a web based training course. http://rhu1.corp.redhat.com/rhutc/ENG112.Content/syllabus.html  
Nice instructional video on how to use Bugzilla from a member of the Mozilla community. Not real long but interesting to watch.  http://blog.johnath.com/2010/02/04/bugzilla-for-humans/ 

Existing Jira training to refer to: https://docspace.corp.redhat.com/docs/DOC-38938

This should be assigned to Lukas Petrovicky.  Mike Harvey and others in QE will contribute
Comment 1 Mike Harvey 2010-05-20 13:44:18 EDT
Hi Lukas,

I have been meaning to discuss this task with you.  Are you comfortable with the task?  Do you have any questions?  Do you have a sense of how much time you will need?

Ping me on IRC and we'll have a phone call and talk if that helps or you can schedule a time on my calendar if you prefer.

Thanks,

Mike
Comment 2 Lukáš Petrovický 2010-06-02 05:09:34 EDT
Hello Mike,

I just noticed I wasn't receiving any e-mails from Bugzilla for the past couple of weeks. :-/ I'm just getting to this bug now.

The current situation is that I am on an unpaid leave until at least 20th June. When I'm back at work on 21st, I will have to work on a test plan for a release, it is due 29th. But after that, I should be generally available to work on this ref sheet.

I will have to think about the specific details of the document obviously, but I think such a ref sheet shouldn't take me more than a week or two to make. The biggest problem is my absence for the next three weeks - if that is an issue, then someone else will have to create the sheet instead.

However, I understand that my BRMS will be the first product to use Bugzilla, so I should be able to work on the sheet while I work on BRMS.
Comment 3 Mike Harvey 2010-06-07 10:46:41 EDT
(In reply to comment #2)
> Hello Mike,
> 
> I just noticed I wasn't receiving any e-mails from Bugzilla for the past couple
> of weeks. :-/ I'm just getting to this bug now.
> 
> The current situation is that I am on an unpaid leave until at least 20th June.
> When I'm back at work on 21st, I will have to work on a test plan for a
> release, it is due 29th. But after that, I should be generally available to
> work on this ref sheet.
> 
> I will have to think about the specific details of the document obviously, but
> I think such a ref sheet shouldn't take me more than a week or two to make. The
> biggest problem is my absence for the next three weeks - if that is an issue,
> then someone else will have to create the sheet instead.
> 
> However, I understand that my BRMS will be the first product to use Bugzilla,
> so I should be able to work on the sheet while I work on BRMS.    

Thanks Lukas.  That answered my question.  We plan to do this work in early July.
Comment 4 Mike Harvey 2010-06-08 07:21:09 EDT
Something maybe useful to add to the list of helpful links for the JIRA migration training.

Dave


-------- Original Message --------
Subject: 	Bz quicksearch
Date: 	Mon, 7 Jun 2010 10:38:14 -0400
From: 	Kevin Baker <kbaker@redhat.com>
To: 	David Lawrence <dkl@redhat.com>, Noura Elhawary <nelhawar@redhat.com>, Tony Fu <tfu@redhat.com>


http://people.mozilla.org/~johnath/bugzilla/BeltznerDoesQuicksearch.ogv

it should be easy for us to put together somethhing like this for our
internal groups. Lightweight Just In Time training.

-- 
Kevin Baker
Manager Engineering Operations, Westford          +1 978 392 2442
Comment 5 Mike Harvey 2010-06-30 16:12:17 EDT
(In reply to comment #0)
> The idea is to leverage existing Bugzilla training for the entire Middleware
> team/users (don't reinvent the wheel) and for us (qe) to create a quick
> reference sheet, a how to in Jira mapped to a how to in Bugzilla.
> 
> Potential subject matter for Jira--> Bugzilla quick reference sheet:
> 
> - How to create a bug
> - Required Fields/Field usage
> - Field Mapping:  Jira--> Bugzilla
> - State Mapping:  open, coding in progress, resolved, closed,
> reopened-->Bugzilla "states"
> - Workflow/routing Mapping:  How bugs typically flow through the system. Maybe
> we can start with two pictures and see if they can be merged into one picture??
> - permissions schemes, visibility
> - dashboard
> - Navigation Tips/Reporting tips (bugzilla shared queries)
> 
> 
> Existing Bugzilla Training Resources to leverage:
> ENG110 Bugzilla Process and Browser Interface This fundamental Red Hat
> Engineering course addresses Bugzilla, how it is used at Red Hat, the flow of a
> bug through the system, and usage of the web interface. Web based training
> course. http://rhu.gsslab.rdu.redhat.com/rhutc/ENG110.Bugzilla/syllabus.html  
> ENG112 - Content Defintion Workflow.  Learn about the infamous three ACKS! This
> is a web based training course.
> http://rhu1.corp.redhat.com/rhutc/ENG112.Content/syllabus.html  
> Nice instructional video on how to use Bugzilla from a member of the Mozilla
> community. Not real long but interesting to watch. 
> http://blog.johnath.com/2010/02/04/bugzilla-for-humans/ 
> 
> Existing Jira training to refer to:
> https://docspace.corp.redhat.com/docs/DOC-38938
> 
> This should be assigned to Lukas Petrovicky.  Mike Harvey and others in QE will
> contribute    

The idea behind this bugzilla task is to provide a short, succinct  "cheat sheet"...a quick reference how to.  This doc is not intended to replace or duplicate and other bugzilla training.  For reference, I have provided a link to other ongoing work: Updating Bugzilla Training https://docspace.corp.redhat.com/docs/DOC-42380
Comment 6 Mike Harvey 2010-07-15 10:51:33 EDT
Content for our quick Reference Sheet


- Max question, can a saved query be shared? yes  made public?  yes.  If the query author changes the search criteria, yes, the next time others run the query, they will see the result of the new query.
Here's some instruction:
How to save a bugzilla query/search and share it:  Search>  Advanced Search> select search criteria and hit "search button.  At the bottom of the page, enter search name in dialogue box and hit "remember search" button.  You now have a saved search.  
https://bugzilla.redhat.com/userprefs.cgi?tab=saved-searches

Go to, edit saved queries> edit> share with "redhat" (there are many groups to choose from).  You can "run" the search search you just saved and grab the URL and share it.  You can edit the search, change the criteria, run the search, and then hit "remember search" button and this will update the named/saved query.  hmm, I did not see my shared "redhat" search in the long public list...so there seems to be something else I need to do to have my query appear on the public list here: https://bugzilla.redhat.com/userprefs.cgi?tab=saved-searches
Comment 7 Mike Harvey 2010-07-20 10:14:49 EDT
Here's a good link for the cheat sheet: Status, Resolution, and field Usage: https://bugzilla.redhat.com/page.cgi?id=fields.html
Comment 8 Lukáš Petrovický 2010-09-12 11:21:41 EDT
Created attachment 446765 [details]
First shot

First (and admittedly incomplete) shot at providing this document. Any suggestions ranging from content to presentation are welcome.

The idea is to provide tips and tricks for the four major use cases:
- Filing bugs.
- Searching for bugs.
- Monitoring activity.
- Reporting activity.

The target audience is the current staff who are used to work with JIRA. New hires will probably be new to both JIRA and Bugzilla.
Comment 9 Lukáš Petrovický 2010-09-12 11:22:32 EDT
Logging work done.
Comment 10 Lukáš Petrovický 2010-09-13 04:46:11 EDT
Created attachment 446865 [details]
Incremental improvements
Comment 11 Lukáš Petrovický 2010-09-13 04:47:38 EDT
More work.

The "Reporting" section should in my opinion be written by someone who used JIRA reporting and will be using BZ reporting on a regular basis. (That is not me.) May I suggest Len or Mike?
Comment 12 Mike Harvey 2010-09-13 09:27:18 EDT
I agree with you Lukas on reporting.  Let's just omit this from the quick reference sheet.  I think some examples of useful quick searches is what users need for purposes of this doc.  I don't think the majority of the users need reporting.  In fact, I'm currently pursuing a bugzilla reporting ticket with EngOps:

#72136] Middleware Products Bugzilla Metrics - Test Instance 
https://engineering.redhat.com/rt3/Ticket/Display.html?id=72136

Greetings EngOps,

As part of our testing and preparation for migration of middlware products from Jira to Bugzilla, we request that you enable metrics reporting test environment that will mine/graph data from our test migration instance: https://bz-web2-test.devel.redhat.com/ [Open URL]

The metrics I'm referring to are listed under section 1.4 Performance Graphs: https://engineering.redhat.com/program/common/book/Product_Pages/tmp/en-US/html-single/index.html [Open URL]
Ideally, we would just have some graphs for the Middleware products as the current graphs are getting a bit long in the tooth and hard to read.

The Middleware Products to be migrated are listed here: https://engineering.redhat.com/trac/bugzilla/wiki/JiraMigration [Open URL]#MigrationHow-To

Thanks,
Comment 13 Mike Harvey 2010-09-13 09:38:04 EDT
Will the attached Tips and Tricks document include some quick reference UI navigation steps for users new to Bugzilla.  See comment #6 for an example of what I mean.
Comment 14 Mike Harvey 2010-09-14 11:10:56 EDT
Goal of this doc:



1)  most common use cases/bz tasks/interactions. 

2)  quick reference.  New bz user will quickly be able to follow a short list of steps to execute task, use case.

3)  where applicable, you may want to cross reference how a task was done in Jira

4)  Short and sweet.  Ideally, we would keep this to one page.  Limit to the top, most common tasks.  A nice, readable "quick reference" format will be nice.

5)  For more detail information, take the complete training courses offered in RHU.





Example of some Common tasks:



1) How do I log a new bugzilla

2) How do I find/query for a bugzilla

3)  How do I save a query, share a query

4) How do I navigate the UI

5) What's the life of a bz - workflow
...maybe just lift a copy of the image in the bugzilla training slides for this.  Don't re-invent the wheel.
6)  Maybe a pointer to filed definitions/usage
Comment 15 Mike Harvey 2010-09-29 13:58:09 EDT
I'm assigning this back to me.  Len and I are working on a doc...feel free to contribute.  https://docspace.corp.redhat.com/docs/DOC-48329
Comment 16 Mike Harvey 2010-10-08 09:06:06 EDT
JIRA to Bugzilla - "How do I....?" - Cheatsheet
https://docspace.corp.redhat.com/docs/DOC-48329

Note You need to log in before you can comment on or make changes to this bug.