Bug 59018 - Cups doesn't have support for koi8-u and koi8-r encodings
Summary: Cups doesn't have support for koi8-u and koi8-r encodings
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: cups (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-29 13:50 UTC by Leonid Kanter
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 19:22:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that adds support for koi8-r, koi8-u and iso8859-8 (34.70 KB, patch)
2002-01-29 13:51 UTC, Leonid Kanter
no flags Details | Diff

Description Leonid Kanter 2002-01-29 13:50:20 UTC
Description of Problem:

Current cups doesn't have include support for koi8-r and koi8-u encodings that
are being used for Russian and Ukrainian in Red Hat Linux. There is a patch that
adds support for koi8-r, koi8-u and also Hebrew (iso8859-8) encodings.

Comment 1 Leonid Kanter 2002-01-29 13:51:43 UTC
Created attachment 43896 [details]
patch that adds support for koi8-r, koi8-u and iso8859-8

Comment 2 Bernhard Rosenkraenzer 2002-01-29 14:34:33 UTC
Patch added in 1.1.13-1, please let me know if it works.

Comment 3 Leonid Kanter 2002-01-30 14:56:08 UTC
Hmm, I forgot that this patch is not enough. The problem is that fonts in 
/usr/share/cups/fonts/ are without cyrillic glyphs and CUPS understand pfa
format. Fonts in /usr/share/fonts/default/Type1 have all necessary cyrillic
glyphs, but they are in pfb. There are two ways to solve the problem:

1. Convert latest urw-fonts to pfa using t1ascii utility, rename to filenames
expected by CUPS and place in /usr/share/cups/fonts/. Uses much more space than
second way. 

2. Add pfb support to cups, remove fonts from /usr/share/cups/fonts/ and create
symlinks from there to /usr/share/fonts/default/Type1 like this:
/usr/share/cups/fonts/AvantGarde-Book ->
/usr/share/fonts/default/Type1/a010013l.pfb and so on.

Which way would be preferable for Red Hat package? Both are verified.

Comment 4 Bernhard Rosenkraenzer 2002-01-31 12:03:14 UTC
cups pstoraster will go away in the next release, maintaining it in 
ghostscript makes more sense.

Comment 5 Leonid Kanter 2002-02-01 14:53:53 UTC
koi8-r and koi8-u support appeared yesterday in cups-1.1.13.

Comment 6 Tim Waugh 2002-10-07 20:53:52 UTC
So this is fixed in 1.1.15?


Note You need to log in before you can comment on or make changes to this bug.