Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 590188 - RHEL 5 guest memory inflates to ridiculous size (179.13 GB) and boot fails
RHEL 5 guest memory inflates to ridiculous size (179.13 GB) and boot fails
Status: CLOSED DUPLICATE of bug 566261
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 20:19 EDT by Zachary Amsden
Modified: 2010-05-10 08:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 08:38:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of guest panic (29.27 KB, image/png)
2010-05-07 20:21 EDT, Zachary Amsden
no flags Details
screenshot of virt-manager (249.28 KB, image/png)
2010-05-07 20:22 EDT, Zachary Amsden
no flags Details
Screenshot showing reported memory and actual size in top (197.21 KB, image/png)
2010-05-07 20:22 EDT, Zachary Amsden
no flags Details

  None (edit)
Description Zachary Amsden 2010-05-07 20:19:24 EDT
Description of problem:

Power on of 64-bit Linux guest in virt manager blew up completely.  System hangs with kernel panic at "Starting udev" and virt management tools say the VM is consuming 179.13 GB of memory.  This is clearly impossible.

Guest was an old guest which worked fine in RHEL 5.5 virt-manager, on a filesystem shared with a RHEL 6 boot.  I created a new VM in virt manager using the old disk.

Attempts to set guest memory back to 512 M resulted in the same failure.  So did 1GB.  I removed the virtio disk over concern it could be causing the boot to fail.  The guest with IDE disk failed the same way.

Running qemu-kvm from the command line did not exhibit the problem; this leads me to suspect something in libvirt or virt-manager running afoul.

Version-Release number of selected component (if applicable):


How reproducible:  100%


Steps to Reproduce:
1.  Create VM from existing disk
2.  Go through silly ISO media exercise.. no media or install needed
3.  Disconnect CDROM, power off and back on
  
Actual results:

Massive memory usage reported by virt monitoring tools; not reported as such by kernel or qemu process.

Expected results:

Boots fine

Additional info:

python-virtinst-0.500.1-3.el6.noarch
fence-virtd-libvirt-0.2.1-3.el6.x86_64
libvirt-python-0.7.6-2.el6.x86_64
virt-manager-0.8.2-3.el6.noarch
fence-virtd-serial-0.2.1-3.el6.x86_64
virt-top-1.0.4-3.1.el6.x86_64
libvirt-qpid-0.2.17-7.el6.x86_64
libvirt-cim-0.5.8-1.el6.x86_64
virt-viewer-0.2.1-1.el6.x86_64
virt-v2v-0.2.0-2.el6.x86_64
libvirt-java-0.4.1-1.el6.noarch
fence-virtd-0.2.1-3.el6.x86_64
libvirt-client-0.7.6-2.el6.x86_64
libvirt-0.7.6-2.el6.x86_64
fence-virtd-multicast-0.2.1-3.el6.x86_64
qemu-kvm-0.12.1.2-2.17.el6.x86_64
qemu-kvm-tools-0.12.1.2-2.17.el6.x86_64
Comment 1 Zachary Amsden 2010-05-07 20:21:02 EDT
Created attachment 412465 [details]
Screenshot of guest panic
Comment 2 Zachary Amsden 2010-05-07 20:22:01 EDT
Created attachment 412466 [details]
screenshot of virt-manager
Comment 3 Zachary Amsden 2010-05-07 20:22:44 EDT
Created attachment 412467 [details]
Screenshot showing reported memory and actual size in top
Comment 5 RHEL Product and Program Management 2010-05-07 21:35:44 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Cole Robinson 2010-05-10 08:38:26 EDT
Pretty sure this was a libvirt bug affecting the beta, should be fixed with newer builds.

*** This bug has been marked as a duplicate of bug 566261 ***

Note You need to log in before you can comment on or make changes to this bug.