Bug 590193 - [abrt] crash in system-config-printer-1.2.0-4.fc13: system-config-printer.py:6176:fillModelList:AttributeError: 'NoneType' object has no attribute 'lower'
Summary: [abrt] crash in system-config-printer-1.2.0-4.fc13: system-config-printer.py:...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:39b383d5
: 598590 (view as bug list)
Depends On:
Blocks: 592346
TreeView+ depends on / blocked
 
Reported: 2010-05-08 01:52 UTC by Edgar Rodolfo
Modified: 2010-07-27 02:53 UTC (History)
3 users (show)

Fixed In Version: system-config-printer-1.1.19-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 592346 (view as bug list)
Environment:
Last Closed: 2010-06-04 18:54:17 UTC


Attachments (Terms of Use)
File: backtrace (976 bytes, text/plain)
2010-05-08 01:52 UTC, Edgar Rodolfo
no flags Details

Description Edgar Rodolfo 2010-05-08 01:52:40 UTC
abrt 1.0.8 detected a crash.

architecture: i686
cmdline: python /usr/share/system-config-printer/system-config-printer.py
comment: lexmark x1100, i don't know fedora 13
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.33.1-24.fc13.i686.PAE
package: system-config-printer-1.2.0-4.fc13
reason: system-config-printer.py:6176:fillModelList:AttributeError: 'NoneType' object has no attribute 'lower'
release: Fedora release 13 (Goddard)

backtrace
-----
system-config-printer.py:6176:fillModelList:AttributeError: 'NoneType' object has no attribute 'lower'

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 6169, in on_tvNPMakes_cursor_changed
    self.fillModelList()
  File "/usr/share/system-config-printer/system-config-printer.py", line 6176, in fillModelList
    is_auto_make = self.NPMake.lower () == self.auto_make.lower ()
AttributeError: 'NoneType' object has no attribute 'lower'

Local variables in innermost frame:
models: [u'PCL 4 LF Printer', u'PCL 4 Printer', u'PCL 5 LF Printer', u'PCL 5 Printer', u'PCL 5c LF Printer', u'PCL 5c Printer', u'PCL 5e LF Printer', u'PCL 5e Printer', u'PCL 6/PCL XL LF Printer', u'PCL 6/PCL XL Printer', u'PCL Laser Printer', u'PostScript Printer', u'Raw Queue', u'text-only printer']
model: <gtk.ListStore object at 0x9ed2374 (GtkListStore at 0x9bda8e0)>
selected: False
self: <__main__.NewPrinterGUI instance at 0x9a30c2c>

Comment 1 Edgar Rodolfo 2010-05-08 01:52:43 UTC
Created attachment 412471 [details]
File: backtrace

Comment 2 Edgar Rodolfo 2010-05-08 12:17:00 UTC

How to reproduce
-----
1.i don't print with fedora 13
2.print usb, but it isn't in db of fedora 13
3.help me!!!
4.-gutenprint-cups cups

Comment
-----
lexmark x1100, i don't know fedora 13

Comment 3 Tim Waugh 2010-05-10 11:52:27 UTC
Fixed upstream (835dfb).

Comment 4 Fedora Update System 2010-05-18 14:52:01 UTC
system-config-printer-1.1.19-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/system-config-printer-1.1.19-1.fc11

Comment 5 Fedora Update System 2010-05-18 14:54:11 UTC
system-config-printer-1.1.19-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/system-config-printer-1.1.19-1.fc12

Comment 6 Fedora Update System 2010-05-19 19:17:02 UTC
system-config-printer-1.1.19-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-printer-1.1.19-1.fc11

Comment 7 Fedora Update System 2010-05-19 19:21:33 UTC
system-config-printer-1.1.19-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-printer-1.1.19-1.fc12

Comment 8 Jiri Popelka 2010-06-02 11:46:58 UTC
*** Bug 598590 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2010-06-02 16:38:24 UTC
system-config-printer-1.2.2-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-printer-1.2.2-4.fc13

Comment 10 Fedora Update System 2010-06-03 18:09:44 UTC
system-config-printer-1.2.2-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-printer-1.2.2-4.fc13

Comment 11 Fedora Update System 2010-06-04 18:53:45 UTC
system-config-printer-1.2.2-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-07-27 02:52:01 UTC
system-config-printer-1.1.19-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.