Bug 590204 - UserList.do (All Users tab) pagination bug: only sees the 1st pageful
Summary: UserList.do (All Users tab) pagination bug: only sees the 1st pageful
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server   
(Show other bugs)
Version: 520
Hardware: All
OS: Linux
urgent
medium
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Dimitar Yordanov
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks: sat531-triage
TreeView+ depends on / blocked
 
Reported: 2010-05-08 04:24 UTC by Xixi
Modified: 2018-10-27 13:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-18 08:27:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0897 normal SHIPPED_LIVE Red Hat Network Satellite bug fix update 2010-11-18 08:27:31 UTC

Description Xixi 2010-05-08 04:24:56 UTC
Description of problem:
Customer tries to remove a package from a number of systems (~11.000) via SSM on upgraded 5.3.0 satellite. After confirm the uninstallation WebUI runs into an error and some time later we found java core and heapdump in /tmp on satellite server.

Version-Release number of selected component (if applicable):
Red Hat Network (RHN) Satellite 5.3.0

How reproducible:
Always.

Steps to Reproduce:
1. Select User tab and then admin user, have at least 6 users.
2. Change RHN List Page Size to a low value, say 5.
3. Click on All (UserList.do) from the Users tab

Actual results:
5 users with no option to view the other users - i.e., "1 - 5 of 5" 

Expected results:
working pagination, i.e., "1 - 5 of 6" & arrows

Additional info:
This appears to be a regression, it was last working in Satellite 5.0.1.

Comment 1 Justin Sherrill 2010-05-13 18:16:05 UTC
Action list code wasn't working properly:

d152d9402cf1bac5c0b9291f579735e944aef611

Comment 3 Dimitar Yordanov 2010-09-03 11:28:57 UTC
Hi all,

 I managed to reproduce the Bug on RHEL5 and updating the system with the following list of packages fixed the problem.

  spacewalk-java-lib-0.5.44-91.el5sat.noarch.rpm  	 	 	
  spacewalk-taskomatic-0.5.44-91.el5sat.noarch.rpm 			
  spacewalk-java-config-0.5.44-91.el5sat.noarch.rpm 			
  spacewalk-java-0.5.44-91.el5sat.noarch.rpm

I could not manage to reproduce the Bug on RHEL4. I guess the problem was never relevant to RHEL4.

Regards
Dimitar Yordanov

Comment 5 errata-xmlrpc 2010-11-18 08:27:46 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0897.html


Note You need to log in before you can comment on or make changes to this bug.