Bug 590213 - procmail not reading /etc/procmailrc
Summary: procmail not reading /etc/procmailrc
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: procmail   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-08 06:27 UTC by Trever Adams
Modified: 2010-05-21 03:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-21 03:05:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Trever Adams 2010-05-08 06:27:45 UTC
procmail: Couldn't chdir to "//Maildir/" procmail: Error while writing to ...

I get this error over and over. Nothing in configuration changed.

As everything worked fine before a yum upgrade, it seems thatsomething in the following files has caused procmail to fail to work,

May 07 11:59:25 Updated: foomatic-db-filesystem-4.0-15.20100204.fc13.noarch
May 07 11:59:49 Updated: foomatic-db-ppds-4.0-15.20100204.fc13.noarch
May 07 12:01:05 Updated: selinux-policy-3.7.19-13.fc13.noarch
May 07 12:01:07 Updated: PackageKit-gtk-module-0.6.4-1.fc13.i686
May 07 12:01:11 Updated: PackageKit-glib-0.6.4-1.fc13.i686
May 07 12:01:12 Updated: PackageKit-yum-plugin-0.6.4-1.fc13.i686
May 07 12:01:24 Updated: PackageKit-0.6.4-1.fc13.i686
May 07 12:01:27 Updated: PackageKit-yum-0.6.4-1.fc13.i686
May 07 12:01:29 Updated: x264-libs-0.0.0-0.27.20100130git3659b81.fc13.i686
May 07 12:01:32 Updated: ffmpeg-libs-0.6-0.3.20100429svn.fc13.i686
May 07 12:01:33 Updated: ffmpeg-0.6-0.3.20100429svn.fc13.i686
May 07 12:01:34 Updated: PackageKit-device-rebind-0.6.4-1.fc13.i686
May 07 12:01:38 Updated: upower-0.9.3-1.fc13.i686
May 07 12:01:40 Updated: 1:wpa_supplicant-0.6.8-9.fc13.i686
May 07 12:03:33 Updated: selinux-policy-targeted-3.7.19-13.fc13.noarch
May 07 12:04:01 Updated: foomatic-db-4.0-15.20100204.fc13.noarch
May 07 12:04:13 Updated: fedora-logos-13.0.2-1.fc13.noarch
May 07 12:04:17 Updated: xkeyboard-config-1.8-6.fc13.noarch
May 07 13:59:38 Updated: libgcc-4.4.4-2.fc13.i686
May 07 13:59:45 Updated: kernel-headers-2.6.33.3-85.fc13.i686
May 07 13:59:48 Updated: system-config-users-1.2.97-1.fc13.noarch
May 07 14:00:02 Updated: fedora-release-notes-13-3.fc13.noarch
May 07 14:00:33 Updated: glibc-common-2.12-1.i686
May 07 14:00:47 Updated: glibc-2.12-1.i686
May 07 14:00:48 Updated: libstdc++-4.4.4-2.fc13.i686
May 07 14:00:49 Updated: nautilus-extensions-2.30.1-3.fc13.i686
May 07 14:01:10 Updated: nautilus-2.30.1-3.fc13.i686
May 07 14:01:12 Updated: libgomp-4.4.4-2.fc13.i686
May 07 14:01:13 Updated: libtool-ltdl-2.2.6-20.fc13.i686
May 07 14:01:16 Updated: cpp-4.4.4-2.fc13.i686
May 07 14:01:36 Installed: kernel-2.6.33.3-85.fc13.i686
May 07 14:01:38 Updated: xorg-x11-drv-intel-2.11.0-4.fc13.i686
May 07 14:01:46 Updated: unixODBC-2.2.14-11.fc13.i686
May 07 14:01:55 Updated: 1:valgrind-3.5.0-17.fc13.i686
May 07 14:01:58 Updated: nscd-2.12-1.i686
May 07 14:02:00 Updated: parted-2.1-8.fc13.i686
May 07 14:02:02 Updated: pygobject2-2.21.1-6.fc13.i686
May 07 14:02:11 Updated: libgcj-4.4.4-2.fc13.i686
May 07 14:02:18 Updated: libstdc++-devel-4.4.4-2.fc13.i686
May 07 14:02:23 Updated: glibc-headers-2.12-1.i686
May 07 14:02:24 Updated: glibc-devel-2.12-1.i686
May 07 14:02:28 Updated: gcc-4.4.4-2.fc13.i686
May 07 14:02:31 Updated: gcc-c++-4.4.4-2.fc13.i686
May 07 14:02:32 Updated: libtool-2.2.6-20.fc13.i686

My guess is glibc, selinux or kernel related stuff.

Comment 1 Trever Adams 2010-05-08 07:46:39 UTC
This may actually be some weird amavisd-new bug. I am still investigating. (My setup is fetchmail -> postfix -> amavisd-new -> postfix -> dspam -> postfix -> procmail.

I found a few strange bugs in my amavisd-new setup (I have a custom configuration). With the new default config it is barfing on some DB (db4, db4-devel stuff claiming a version mismatch, witch based on rpm -q is not true). I customized the current amvisd-new config and disabled the db4 stuff. The problem with procmail seems to have miraculously disappeared, please leave this open while I try to figure out what is going on and why it just suddenly broke.

Comment 2 Trever Adams 2010-05-21 03:05:41 UTC
This is really strange. Something in the problem with amavisd-new was causing the problem. I still don't understand how it was showing up as it was, but the problem is gone.


Note You need to log in before you can comment on or make changes to this bug.