Bug 590214 - [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
[abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox wa...
Status: CLOSED DUPLICATE of bug 543165
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:2f336cf73d4f38b64a1d1e2aa3c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-08 02:39 EDT by Jesse Larrew
Modified: 2010-05-08 11:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-08 11:11:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (49.93 KB, text/plain)
2010-05-08 02:39 EDT, Jesse Larrew
no flags Details

  None (edit)
Description Jesse Larrew 2010-05-08 02:39:20 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.5/firefox
comment: Segfault after closing Firefox.
component: firefox
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib/firefox-3.5/firefox
global_uuid: 2f336cf73d4f38b64a1d1e2aa3c5c0f115e2a482
kernel: 2.6.32.11-99.fc12.i686.PAE
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Start Firefox,
2. Open several tabs (10-20),
3. Close Firefox.
Comment 1 Jesse Larrew 2010-05-08 02:39:23 EDT
Created attachment 412488 [details]
File: backtrace
Comment 2 Chris Campbell 2010-05-08 11:04:58 EDT
#5  <signal handler called>
No symbol table info available.
#6  0x00961c7e in IA__g_type_check_instance (type_instance=0xaf4f3180)
    at gtype.c:3806
        node = 0x428b0424
#7  0x00960fa6 in IA__g_signal_handlers_disconnect_matched (instance=
    0xaf4f3180, mask=24, signal_id=0, detail=0, closure=0x0, func=0x33c4b80, 
    data=0xa8dd3f80) at gsignal.c:2667
        _g_boolean_var_ = <value optimized out>
        n_handlers = 0
        __PRETTY_FUNCTION__ = "IA__g_signal_handlers_disconnect_matched"
#8  0x033c55de in update_client_widget (context_xim=
    0xa8dd3f80 [GtkIMContextXIM], client_window=<value optimized out>)
    at gtkimcontextxim.c:1641
        new_client_widget = 0x0
#9  set_ic_client_window (context_xim=0xa8dd3f80 [GtkIMContextXIM], 
    client_window=<value optimized out>) at gtkimcontextxim.c:654
No locals.
#10 0x033c5681 in xim_info_display_closed (display=
    0xb7584140 [GdkDisplayX11], is_error=0, info=0xb4327c80)
    at gtkimcontextxim.c:402
        ics = 0xa89cf480 = {0xa8dd3f80, 0xa62b2780, 0x91abb600, 0x91abb400, 
    0x99bdbb80, 0x91ac7d00, 0x91a27c80, 0x96da8a00}
        tmp_list = 0xa89cf480 = {0xa8dd3f80, 0xa62b2780, 0x91abb600, 
    0x91abb400, 0x99bdbb80, 0x91ac7d00, 0x91a27c80, 0x96da8a00}
#11 0x00957218 in IA__g_cclosure_marshal_VOID__BOOLEAN (closure=0xb491e1a0, 
    return_value=0x0, n_param_values=2, param_values=0x91011040, 
    invocation_hint=0xbfb7a7c0, marshal_data=0x0) at gmarshal.c:111
        callback = 0x33c5630 <xim_info_display_closed>
        cc = 0xb491e1a0
        data1 = <value optimized out>
        data2 = 0xb4327c80
        __PRETTY_FUNCTION__ = "IA__g_cclosure_marshal_VOID__BOOLEAN"
#12 0x009495b3 in IA__g_closure_invoke (closure=0xb491e1a0, return_value=0x0, 
    n_param_values=2, param_values=0x91011040, invocation_hint=0xbfb7a7c0)
    at gclosure.c:767
        marshal = <value optimized out>
        marshal_data = <value optimized out>
        in_marshal = -1273044480
        __PRETTY_FUNCTION__ = "IA__g_closure_invoke"
#13 0x0095f118 in signal_emit_unlocked_R (node=0xb75756d0, detail=0, instance=
    0xb7584140, emission_return=0x0, instance_and_params=0x91011040)
    at gsignal.c:3247
        tmp = <value optimized out>
        handler = 0xb491e180
        accumulator = 0x0
        emission = {next = 0x0, instance = 0xb7584140, ihint = {signal_id = 
    3, detail = 0, run_type = G_SIGNAL_RUN_FIRST}, state = EMISSION_RUN, 
          chain_type = 4}
        class_closure = 0xb7573720
        handler_list = 0xb46d3c20
        return_accu = 0x0
        accu = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0, 
              v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 
    0, v_pointer = 0x0}, {v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, 
              v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, 
              v_pointer = 0x0}}}
        signal_id = 3
        max_sequential_handler_number = 12243
        return_value_altered = 1



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Chris Campbell 2010-05-08 11:11:43 EDT
Thank you for taking the time to submit this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 543165 ***

Note You need to log in before you can comment on or make changes to this bug.