Bug 590216 - Graphical glitches with NVa0 (GT200b [GeForce GTX 285])
Summary: Graphical glitches with NVa0 (GT200b [GeForce GTX 285])
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-08 06:58 UTC by Peter Hjalmarsson
Modified: 2010-05-12 12:16 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-drv-nouveau-0.0.16-5.20100423git13c1043.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-12 12:16:48 UTC
Type: ---


Attachments (Terms of Use)
Screenshot of the corruption (143.36 KB, image/png)
2010-05-08 06:58 UTC, Peter Hjalmarsson
no flags Details
Xorg.log (135.67 KB, text/plain)
2010-05-08 06:59 UTC, Peter Hjalmarsson
no flags Details
dmesg (56.24 KB, text/plain)
2010-05-08 07:00 UTC, Peter Hjalmarsson
no flags Details

Description Peter Hjalmarsson 2010-05-08 06:58:54 UTC
Created attachment 412490 [details]
Screenshot of the corruption

Description of problem:
When gdm has started I see glitches a little bit from the top left corner of the screen (screenshot provided) that comes and goes. The image in this distortion is sometime worse and sometimes better. And sometimes you can almost not see the distortion at all.

Version-Release number of selected component (if applicable):
I have an up to date system against updates testing.
Linux lillen.dodi 2.6.33.3-79.fc13.x86_64 #1 SMP Mon May 3 22:37:18 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
xorg-x11-server-Xorg.x86_64         1.8.0-12.fc13
xorg-x11-drv-nouveau.x86_64         1:0.0.16-3.20100305git6b8b157.fc13
libdrm.x86_64                       2.4.20-1.fc13

How reproducible:
Always there, more or less 95% of the time I use the computer.

Steps to Reproduce:
1. Start Fedora13, either liveusb or installed from it.
  
Actual results:
A part of the screen shows distorted versions of objects or other parts of the screen.

Expected results:
The screen should be consistent.

Additional info:
I also from time to time have problems with the colours of fonts. They can become grayis and also disappere (or maybe take the colour of the background, same thing visually). I do not know if this is related or another bug.
I have memories of having the same corruption like this while using Gentoo, nouveau and upgrading from xserver-1.6 to 1.7 (or if it was 1.5 to 1.6, cannot really remember any more). That time around it worked in Fedora, and talking to the guys in #nouveau they told me that Fedora had a workaround/hack that made Fedora12 work (like it still does), however that hack seems to have been dropped for Fedora 13.

Comment 1 Peter Hjalmarsson 2010-05-08 06:59:33 UTC
Created attachment 412491 [details]
Xorg.log

Comment 2 Peter Hjalmarsson 2010-05-08 07:00:34 UTC
Created attachment 412492 [details]
dmesg

Comment 3 Ben Skeggs 2010-05-09 22:46:29 UTC
Are you able to install the build at http://koji.fedoraproject.org/koji/taskinfo?taskID=2176109 and see if it helps your issue.

It should, the code was in F12 for this exact reason, but this should've been fixed elsewhere for F13, obviously not :)

Comment 4 Peter Hjalmarsson 2010-05-10 15:11:22 UTC
(In reply to comment #3)
> Are you able to install the build at
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2176109 and see if it helps
> your issue.
> 
Yes, all graphical glitches is gone with that build.

> It should, the code was in F12 for this exact reason, but this should've been
> fixed elsewhere for F13, obviously not :)    

Heh, yeah, I guessed that was the reason for the fix not being present. If this is still not a "proper" fix and you need testing or info to iron it out, just shout at me.;)

Comment 5 Ben Skeggs 2010-05-10 22:33:31 UTC
I'd be interested in knowing how much vram your card has, and the memory bus width (if you know it by chance).

It's still not a proper fix, but I'll still put it into F13 as it's the only viable way of fixing it right now, and doesn't have much of an impact.

Comment 6 Fedora Update System 2010-05-11 00:21:00 UTC
xorg-x11-drv-nouveau-0.0.16-5.20100423git13c1043.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xorg-x11-drv-nouveau-0.0.16-5.20100423git13c1043.fc13

Comment 7 Peter Hjalmarsson 2010-05-11 06:59:42 UTC
(In reply to comment #5)
> I'd be interested in knowing how much vram your card has, and the memory bus
> width (if you know it by chance).
> 
According to gpu-z the memory size of the card is 1024MB, the bus width is 512 bits. It seems accurate with what I remeber when I bought the card.

> It's still not a proper fix, but I'll still put it into F13 as it's the only
> viable way of fixing it right now, and doesn't have much of an impact.    

Yeah, the hack has been "well tested" with Fedora 12, and not much time before F13 is released I can see what you mean.

Anyway if you need more info or have a patch or a build or anything you want to test, just drop me a line. I know my way around computers, but am not a codemonkey so I can do most stuff but help with the actual code.

Comment 8 Fedora Update System 2010-05-12 12:16:43 UTC
xorg-x11-drv-nouveau-0.0.16-5.20100423git13c1043.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.