Bug 590222 - nouveau driver not working with NVIDIA Quadro NVS 295 card
nouveau driver not working with NVIDIA Quadro NVS 295 card
Status: CLOSED DUPLICATE of bug 596703
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-nouveau (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ben Skeggs
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-08 03:45 EDT by Praveen Arimbrathodiyil
Modified: 2013-06-17 00:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 22:28:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (215.87 KB, text/plain)
2010-05-10 02:19 EDT, Praveen Arimbrathodiyil
no flags Details
/var/log/Xorg.0.log (44.97 KB, text/plain)
2010-05-10 02:20 EDT, Praveen Arimbrathodiyil
no flags Details
Xorg.0.log with nv driver (69.05 KB, text/plain)
2010-05-10 02:51 EDT, Praveen Arimbrathodiyil
no flags Details
Xorg.0.log with -24 kernel (45.21 KB, text/plain)
2010-05-10 03:37 EDT, Praveen Arimbrathodiyil
no flags Details
/var/log/messages with -24 kernel (520.86 KB, text/plain)
2010-05-10 04:14 EDT, Praveen Arimbrathodiyil
no flags Details

  None (edit)
Description Praveen Arimbrathodiyil 2010-05-08 03:45:04 EDT
Description of problem:

Maximum resolution on a 22 inch monitor available is 1280 x 720, which is not a good resolution to work with (panels and window borders are very wide and ugly)

$ xrandr 
Screen 0: minimum 640 x 480, current 1280 x 720, maximum 1280 x 720
default connected 1280x720+0+0 0mm x 0mm
   1280x720        0.0* 
   800x600        61.0  
   640x480        60.0  

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. login to a graphical desktop
2. look at the resolution
3.
  
Actual results:

small resolution

Expected results:

higher resolution

Additional info:
Comment 1 Praveen Arimbrathodiyil 2010-05-08 03:46:51 EDT
$ lspci |grep -i vga
02:00.0 VGA compatible controller: nVidia Corporation Device 06fd (rev a1)
Comment 2 Praveen Arimbrathodiyil 2010-05-08 03:48:43 EDT
Same monitor accessed via Lenovo T400 laptop gives a resolution of 1680x1050

VGA1 connected (normal left inverted right x axis y axis)
   1680x1050      60.0 +
   1280x1024      75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  

graphics card on the laptop is 

$ lspci |grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Comment 4 RHEL Product and Program Management 2010-05-08 05:28:40 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Ben Skeggs 2010-05-09 18:15:35 EDT
It would be great if you could attach /var/log/Xorg.0.log and /var/log/messages.
Comment 6 Praveen Arimbrathodiyil 2010-05-10 02:19:40 EDT
Created attachment 412721 [details]
/var/log/messages
Comment 7 Praveen Arimbrathodiyil 2010-05-10 02:20:26 EDT
Created attachment 412722 [details]
/var/log/Xorg.0.log
Comment 8 Praveen Arimbrathodiyil 2010-05-10 02:23:15 EDT
Looks like it is falling back to vesa. anaconda was failing to start X in previous versions (before snapshot 2) as well.

[drm] failed to load kernel module "nouveau"
(EE) [drm] failed to open device
Comment 9 Ben Skeggs 2010-05-10 02:46:08 EDT
Yeah, due to a series of unfortunate incidents nouveau didn't work for a few kernel revisions.  2.6.32-23.el6.x86_64 (your kernel) didn't have nouveau *at all*, 2.6.32-24.el6.x86_64 is fixed though.

If you could update to that, and try again that'd be great.
Comment 10 Praveen Arimbrathodiyil 2010-05-10 02:50:48 EDT
Ok, I'll update the kernel. Meanwhile I was trying "nv" driver. It gave 1680x1050 resolution but it was not usable at all - the screen looked like a oil painting - random colors. I have Xorg.0.log with nv driver - which has much more info about the graphics card.
Comment 11 Praveen Arimbrathodiyil 2010-05-10 02:51:34 EDT
Created attachment 412726 [details]
Xorg.0.log with nv driver
Comment 12 Praveen Arimbrathodiyil 2010-05-10 03:20:24 EDT
I updated the kernel from brew, but now after grub the screen is blank - monitor goes to power saving mode :( This is the behavior of anaconda with most other trees (rhel beta, fedora beta, fedora 13 rawhide ...)
Comment 13 Ben Skeggs 2010-05-10 03:34:41 EDT
Okay, can you attach /var/log/messages from after the failed boot, I'll see if there's something obvious that sticks out.
Comment 14 Praveen Arimbrathodiyil 2010-05-10 03:37:59 EDT
Created attachment 412742 [details]
Xorg.0.log with -24 kernel

Now I get more verbose messages, I removed "rhgb quiet" from boot line and added nomodeset. 

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenByBusid: Searching for BusID pci:0000:02:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenByBusid: drmOpenMinor returns 8
drmOpenByBusid: drmGetBusid reports pci:0000:02:00.0
(EE) [drm] failed to open device
Comment 15 Praveen Arimbrathodiyil 2010-05-10 04:14:21 EDT
Created attachment 412750 [details]
/var/log/messages with -24 kernel
Comment 16 Ben Skeggs 2010-05-10 19:08:59 EDT
For comment 14: this is expected, nouveau can't operate with "nomodeset" any longer.
Comment 17 Ben Skeggs 2010-05-10 19:09:32 EDT
Praveen: Can you reproduce this issue with other displays, or just this one?
Comment 18 Praveen Arimbrathodiyil 2010-05-11 03:57:05 EDT
Ben: It happens with other displays also, I tested with a Dell 17 inch monitor.
Comment 19 Ben Skeggs 2010-06-28 01:11:33 EDT
Praveen, I managed to get hold of a NVS295 here and have a patch that is able to light up the displays.  I'm still not 100% sure of how this bug *should* be handled, the binary driver and VBIOS do 2 completely different things here.

But, for testing/confirmation, there's a scratch build at: https://brewweb.devel.redhat.com/taskinfo?taskID=2553678

Does this fix the problem for you?
Comment 20 Praveen Arimbrathodiyil 2010-06-28 02:19:50 EDT
Ben,

Thanks, it is working for me. nouveau doesn't give 3d for this card yet, I guess.
Comment 21 Ben Skeggs 2010-06-28 02:25:54 EDT
Thanks for letting me know :)  No, there's an experimental (and buggy) 3D driver available, but we're not shipping it in EL6.
Comment 22 Ben Skeggs 2010-07-07 04:16:19 EDT
I've got another scratch build ready if you can test it for me please.  This should resolve this issue in another way which doesn't break other systems in the process.

https://brewweb.devel.redhat.com/taskinfo?taskID=2577620

Thanks!
Comment 23 Praveen Arimbrathodiyil 2010-07-07 04:38:24 EDT
I don't have that system with me right now, I will get it back by next week. I will test it once I get my system back.
Comment 26 Suzanne Yeghiayan 2010-07-13 22:28:01 EDT

*** This bug has been marked as a duplicate of bug 596703 ***
Comment 27 linferna 2012-08-08 21:41:28 EDT
My experience is with quadro fx 3700 (nvidia). FPD with 1680x1050, RHEL 6.2 boots up no problems - perfect graphics. But yet another FPD with 1920x1680, RHEL 6.2 doesn't boot up, no display (just blank screen). I cannot ping the system, i.e. system is hung. Is there a limitation with maximum resolution that 'nouveau' driver can handle? Are there any special switches? Based on the other reported incidents in here this problem is not limited to NVS 295.
Comment 28 linferna 2012-08-08 21:44:33 EDT
I noticed that if I append "nomodeset" big FPD (preset resoluion 1920x1680) boots up with lower resolution. As per google this is a legacy solution. Any insight is highly appreciated.

Note You need to log in before you can comment on or make changes to this bug.