Bug 590263 - Suspend to ram blocks the system: possible networking problems
Suspend to ram blocks the system: possible networking problems
Status: CLOSED DUPLICATE of bug 583065
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-08 08:40 EDT by Marco Vittorini Orgeas
Modified: 2010-05-12 17:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-12 17:17:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pm-suspend.log relative to one of the failing suspend (4.64 KB, application/octet-stream)
2010-05-08 08:40 EDT, Marco Vittorini Orgeas
no flags Details
Relative /var/log/messages part (38.71 KB, text/plain)
2010-05-08 08:45 EDT, Marco Vittorini Orgeas
no flags Details

  None (edit)
Description Marco Vittorini Orgeas 2010-05-08 08:40:31 EDT
Created attachment 412525 [details]
Pm-suspend.log relative to one of the failing suspend

Description of problem:
Sometimes when suspending to ram, the system starts to execute commands to do suspension, monitor turns off but the fan doesn't stop and the suspending laptop Led (Thinkpad t61) keeps blinking (meaning a suspension underway).
The system no longer
responds nor can be resumed and I have to power it down.
When I then restart the system I ALWAYS find the networking state of the system to disable and I need to restart networking.
Attached logs seems to confirm the possible problem.
So probably a network problem!

How reproducible:
Try to suspend more than one time, doing some network activity between tries. 

Steps to Reproduce:
1.Suspend the system by pressing "System -> Shutdown -> Suspend" (or via
lid closing)
2.Do some network activity (could be not needed)
3.Suspend the system by pressing "System -> Shutdown -> Suspend" (or via
lid closing)
  
Actual results:
The screen switches to console; the hard disk turns off, but the fans continue
spinning; some tens of seconds later, the power button light starts blinking.
The system no longer responds nor can be resumed and I have to power it down.


Expected results:
System should suspend correctly and resume after pressing the power button.

Additional info: uname -a
Linux marco.laptop 2.6.33.3-85.fc13.x86_64 #1 SMP Thu May 6 18:09:49 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Marco Vittorini Orgeas 2010-05-08 08:45:07 EDT
Created attachment 412527 [details]
Relative /var/log/messages part

Look the starting lines relative to the failed suspend attempt
Comment 2 Marco Vittorini Orgeas 2010-05-08 08:49:15 EDT
(In reply to comment #0)

> 
> Actual results:
> The screen switches to console; the hard disk turns off, but the fans continue
> spinning; some tens of seconds later, the power button light starts blinking.
> The system no longer responds nor can be resumed and I have to power it down.
> 

I meant just that the fans don't turn off and the light keeps blinking.
The screen goes off and the system doesn't respond.
This bug could be somewhat related to Bug 583065, but the cadence on which it is reproducible is not always on the second one.
Comment 3 Marco Vittorini Orgeas 2010-05-12 17:17:17 EDT
I'm marking this as duplicate of 583065.
I initially reported this bug, but with the latest kernel upgrade, the problem happens ALWAYS the second time the system is suspended.
So marking as duplicate of 583065.

*** This bug has been marked as a duplicate of bug 583065 ***

Note You need to log in before you can comment on or make changes to this bug.