Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 590302 - Sony Ericsson MD400 mobile broadband modem can't be activated
Sony Ericsson MD400 mobile broadband modem can't be activated
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-08 14:15 EDT by Christian Joensson
Modified: 2012-05-08 09:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 09:16:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
relevant(?) /var/log/messages (8.29 KB, text/plain)
2010-05-08 14:15 EDT, Christian Joensson
no flags Details
Requested additional information. (34.13 KB, text/plain)
2010-05-12 01:43 EDT, Christian Joensson
no flags Details

  None (edit)
Description Christian Joensson 2010-05-08 14:15:26 EDT
Created attachment 412556 [details]
relevant(?) /var/log/messages

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: uhm, always for me...


Steps to Reproduce:
1. insert md400
2. enable mobile broadband
3. try activate operators network access
  
Actual results:

Activation of mobile broadband unsuccessful 

Expected results:

Activation of mobile broadband successful  

Additional info:
Comment 1 Dan Williams 2010-05-10 17:57:07 EDT
We'll need some modem-manager output here.  Check out the "Debugging NetworkManager 0.8.x 3G connections" section of:

http://live.gnome.org/NetworkManager/Debugging

and attach the modem-manager debug output when you can get it?  THanks!
Comment 2 Christian Joensson 2010-05-12 01:43:02 EDT
Created attachment 413329 [details]
Requested additional information.

The debug log files were collected during, insertion, restart in debug mode of NetworkManager and ModemManager, entering SIM PIN code (without successful activation) a few times, enabling Mobile Broadband, trying to activate the operators Mobile Broadband connection (unsuccessful).
Comment 3 Dan Williams 2010-05-14 19:22:43 EDT
So you'll want to make sure "allow roaming when home network is not available" checkbox in nm-connection-editor.  It appears that your SIM detects the network as a roaming network and thus the connection is terminated.  After that, if you pull down the menu, you should see the network listed as "roaming".

GSM connection failed: (32) Roaming is not allowed.

This is a function of your SIM since your provider has set your SIM to detect the network that's being registered with as a roaming network.  I know that telenor and Three share the 3G network, but your modem is detecting the network as a roaming network.

If you re-check the "allow roaming" checkbox, does that solve the problem for you?
Comment 4 Christian Joensson 2010-05-15 14:34:32 EDT
well, roaming outside home network... that box is indeed ticked. I get the network, it's registered as "SWEDEN (UMTS roaming)" but then I cannot activate, i.e., get into that network (under rawhide, I can with other os). I tried booting with selinux=0, same thing. I am a little suspicious on the dbus message being rejected, though...
Comment 5 Dan Williams 2010-05-20 02:56:28 EDT
Hmm, I'll have to add some debugging info to modem-manager to verify that the 'home-only' config option is correct when we send it from NM to MM I guess.  Because that's the only thing I can think of in your case.
Comment 6 Christian Joensson 2010-05-20 06:17:32 EDT
great, pls let me know when and how I can complement this bug report further to your recent proposition
Comment 7 Dan Williams 2010-05-20 16:38:20 EDT
So apparently MVNO networks often show up as roaming networks, which is completely unhelpful.  And there aren't standard commands to get roaming status off the phone besides CREG which in this case reports taht you're roaming, unless the device implements specific commands for this which some do, and most don't.

I still need to verify that home-only works as expected.
Comment 8 Dan Williams 2010-05-25 18:25:39 EDT
I believe home-only works as expected...

There are a few other oddities in the md400 NM/MM logs that I'll have to add more debugging for.
Comment 9 Dan Williams 2010-06-28 17:55:24 EDT
If there's any chance you can connect to the device with minicom when it's in this state, and grab the  output of both:

AT+CIND=?
AT+CIND?

that would be very helpful.  It may be the case that the device's roaming indicator reported by CIND is more useful than CREG.

Also, can you get updated modem-manager logs after installing this version of MM?

http://koji.fedoraproject.org/koji/buildinfo?buildID=180275

(look near the bottom for your architecture, grab the ModemManager package, and use 'rpm -Uhv <rpm file>' to install it).

Thanks!
Comment 10 Christian Joensson 2010-06-29 13:58:29 EDT
well, as of now, I can enable the device. I'm still on rawhide, quite up to date as of today, not able to run the current kernel, am using ModemManager-0.4-2.git20100628.fc14.i686. The NetworkManager icon, I presume, still says UMTS roaming.

let me know if you do indeed need additional info and I will try to produce that to you.
Comment 11 Bug Zapper 2010-07-30 07:34:58 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Dan Winship 2012-05-08 09:16:09 EDT
(In reply to comment #10)
> well, as of now, I can enable the device.

closing then

Note You need to log in before you can comment on or make changes to this bug.