Bug 590340 - Move rpmdb cache to persistent storage
Summary: Move rpmdb cache to persistent storage
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact: Karel Srot
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-08 22:46 UTC by James Antill
Modified: 2014-01-21 06:17 UTC (History)
4 users (show)

Fixed In Version: yum-3.2.27-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 22:00:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Antill 2010-05-08 22:46:46 UTC
Description of problem:
 Atm. the rpmdb cache is in /var/cache/yum/... we've recently moved this (upstream) to /var/lib/yum/rpmdb-indexes because mock will copy all of /var/cache/yum, and then we have problems when the cache doesn't match the rpmdb. We have a workaround for this by using ctime in RHEL-6, but upstream still uses mtime (so we are needlessly different).

 It's also possible that people will share all of /var/cache/yum over NFS/rsync, and thus. run into the same problems.

 Fix is simple, we just change the path.

Version-Release number of selected component (if applicable):
3.2.27-7

Comment 1 RHEL Product and Program Management 2010-05-08 23:26:43 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Jay Greguske 2010-05-11 20:57:52 UTC
I believe this is also impacting the building of LiveCDs in Koji. The yum cache directory left over from the creation of the LiveCD image contains an "installed" directory which makes the Koji code choke. 

This comment is just to make other Rel-Eng folks aware of the issue, I'm going to fix the fragile Koji code myself.

Comment 3 seth vidal 2010-05-11 21:01:31 UTC
There's a patch for mock in upstream which fixes the mock issue.

is the livecd creator using mock at all?

Comment 6 releng-rhel@redhat.com 2010-11-10 22:00:42 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.