Bug 590346 - Preupgrade requires /boot larger than 200MB to upgrade
Preupgrade requires /boot larger than 200MB to upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-08 20:07 EDT by Scott Williams
Modified: 2010-11-03 11:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-03 11:43:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Williams 2010-05-08 20:07:12 EDT
Description of problem:

I have tested this on two machines, one x86_64 and the other i686.  With the new python-urlgrabber, the prompt allows the user to continue and download the images during upgrade.

The problem is:  With a 200MB /boot, and only one kernel installed there is still not enough room for the install images and a wire connection is required for a user to upgrade with preupgrade.

This contradicts Expected Result #3 of https://fedoraproject.org/wiki/QA:Testcase_Preupgrade

Version-Release number of selected component (if applicable):

preupgrade-1.1.5-1

How reproducible:

Every time.

Steps to Reproduce:
1. Ensure there are only 1 kernel installed on the system and /boot is 200MB (the installation default size).
2. Make sure system is up to date.
3. Run preupgrade.
4. On the Choose desired release screen, enable unstable test releases.
5. Choose Fedora 13 (Branched) from the list of available upgrade targets, then click Apply. 
  
Actual results:

User is notified that there is not enough disk space in /boot and user must have a wire connection to download the images during the anaconda upgrade process.

Expected results:

The user is not prompted about low disk space when using preupgrade with the default partition size for /boot.

Additional info:

Since LVM is also a default, having users resize /boot may not be so straightforward.  Would it be possible to store the boot images in the root partition if /boot is not big enough?
Comment 1 Scott Williams 2010-05-08 20:27:33 EDT
Also, I tried this with setting installurl= to make sure it's grabbing the RC2 Final images, and this is a problem as of Final RC2.
Comment 3 Scott Williams 2010-10-23 17:58:59 EDT
If there is another bug before this one that addresses it, please mark this as a duplicate.  I did not see one before posting.
Comment 4 Bug Zapper 2010-11-03 11:17:26 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Kamil Páral 2010-11-03 11:43:54 EDT
This has been fixed with preupgrade-1.1.8-1.fc12.1.

Note You need to log in before you can comment on or make changes to this bug.