Bug 59037 - showmount <host> displays hosts that are no longer using exports
Summary: showmount <host> displays hosts that are no longer using exports
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-29 19:16 UTC by Ben Levenson
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-04 20:06:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Levenson 2002-01-29 19:16:50 UTC
Description of Problem:
showmount returns the hostname for a client that
no longer has the 
exported directory mounted.

from /var/log/messages:
Jan 29 14:00:55 iccthedral 
rpc.mountd: authenticated unmount request from 172.16.47.172:886 for /opt/mp3 
(/opt/mp3)
Jan 29 14:01:00 iccthedral rpc.mountd: dump request from 172.16.45.101
Jan 
29 14:01:12 iccthedral rpc.mountd: dump request from 
172.16.45.101

yet...
[benl@iccthedral benl]$ showmount
Hosts on 
iccthedral.meridian.redhat.com:
dhcpd172.meridian.redhat.com
(dhcpd172 has address 
172.16.47.172)

checking the mounted filesystems on dhcpd172 confirms that
it has 
indeed umounted the exported filesystem from the server
in question.

Version-Release 
number of selected component (if applicable):
nfs-utils-0.3.1-13.7.2.1

Comment 1 Bob Matthews 2002-01-29 19:24:29 UTC
Which kernel is this?

Comment 2 Ben Levenson 2002-01-29 19:56:10 UTC
kernel-2.4.9-21

Comment 3 Bob Matthews 2002-02-04 20:06:16 UTC
Showmount consults the file /var/lib/nfs/rmtab to determine which clients are
mounting partitions from the server.  It looks like this file has become
corrupted.

/var/lib/nfs/rmtab is supposed to be updated whenever a mount/umount request
takes place, but can become corrupted if the client has a partition mounted from
the server and reboots without explicitly unmounting it.

Try clearing out the rmtab file, and let me know if the problem reoccurs.

Comment 4 Ben Levenson 2002-02-20 16:25:25 UTC
OK. I must not have unmounted the filesystem before shutting down...
I'm closing as NOTABUG since I can't reproduce this using the steps
you provide above.
/var/lib/nfs/rmtab is updated as expected when the 'unmount' command is issued
on the client. showmount *does* reflect this.
kernel-2.4.9-26beta.28
nfs-utils-0.3.1-13.7.2.4


Note You need to log in before you can comment on or make changes to this bug.