Bug 590424 - SELinux is preventing /usr/lib64/nspluginwrapper/plugin-config "read" access on plugins-wrapped.
SELinux is preventing /usr/lib64/nspluginwrapper/plugin-config "read" access ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:6de04e3c527...
:
: 590423 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 09:46 EDT by Amit Shah
Modified: 2010-05-10 09:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 09:38:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Shah 2010-05-09 09:46:16 EDT
Summary:

SELinux is preventing /usr/lib64/nspluginwrapper/plugin-config "read" access on
plugins-wrapped.

Detailed Description:

SELinux denied access requested by plugin-config. It is not expected that this
access is required by plugin-config and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:sandbox_x_client_t:s0:c2
                              73,c692
Target Context                system_u:object_r:nsplugin_rw_t:s0
Target Objects                plugins-wrapped [ dir ]
Source                        plugin-config
Source Path                   /usr/lib64/nspluginwrapper/plugin-config
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           nspluginwrapper-1.3.0-11.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-10.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.3-79.fc13.x86_64 #1 SMP Mon May 3 22:37:18
                              UTC 2010 x86_64 x86_64
Alert Count                   4
First Seen                    Sun 09 May 2010 07:09:06 PM IST
Last Seen                     Sun 09 May 2010 07:09:06 PM IST
Local ID                      81dddc41-f8dd-4234-8021-ab420ea98b0b
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273412346.446:47607): avc:  denied  { read } for  pid=3394 comm="plugin-config" name="plugins-wrapped" dev=dm-3 ino=793461 scontext=unconfined_u:unconfined_r:sandbox_x_client_t:s0:c273,c692 tcontext=system_u:object_r:nsplugin_rw_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1273412346.446:47607): arch=c000003e syscall=2 success=no exit=-13 a0=60815f a1=90800 a2=7fffe36881bf a3=1 items=0 ppid=3392 pid=3394 auid=500 uid=500 gid=501 euid=0 suid=0 fsuid=0 egid=501 sgid=501 fsgid=501 tty=(none) ses=1 comm="plugin-config" exe="/usr/lib64/nspluginwrapper/plugin-config" subj=unconfined_u:unconfined_r:sandbox_x_client_t:s0:c273,c692 key=(null)



Hash String generated from  catchall,plugin-config,sandbox_x_client_t,nsplugin_rw_t,dir,read
audit2allow suggests:

#============= sandbox_x_client_t ==============
allow sandbox_x_client_t nsplugin_rw_t:dir read;
Comment 1 Carl G. 2010-05-09 15:59:28 EDT
*** Bug 590423 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2010-05-10 09:38:18 EDT
If you are running firefox or something similar you need to use a context of sandbox_web_t

Note You need to log in before you can comment on or make changes to this bug.