Bug 590448 - Too old for development work
Too old for development work
Status: CLOSED DUPLICATE of bug 575248
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kdebase (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 11:53 EDT by Brandon
Modified: 2010-05-14 07:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 11:45:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brandon 2010-05-09 11:53:02 EDT
Description of problem: KDE 4.3 and Qt 4.5 are too old to be used for development work. Qt 4.6 is a MAJOR update to the Qt framework and KDE 4.3 cannot be built with it. The best option to do is to include both KDE 4.4 and Qt 4.6 for serious developers. Anyone picking a distribution for KDE Software development might be inclined to choose a Novell or Ubuntu offering instead as they offer KDE 4.4+ and Qt 4.6+

Another important point to bring up is that supporting KDE 4.3 and Qt 4.5 for the next 7 years is insane, especially when Qt 4.5 to 4.6 is a MAJOR update and KDE doesn't backport. KDE 4.4 is considered the first usable release to a majority of critics and anyone anticipating a distro release will be disappointed with the old version included in RHEL6.

I looked at where a lot of the packages where branched from, and the F12 stable branch now includes 4.4, it had 4.3 when it was branched last year.


Version-Release number of selected component (if applicable):
4.3

How reproducible:


Steps to Reproduce:
1. Re-branch from F12's current stable repo?
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-05-09 13:20:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Bill Nottingham 2010-05-11 11:45:31 EDT

*** This bug has been marked as a duplicate of bug 575248 ***
Comment 4 Brandon 2010-05-11 15:43:42 EDT
It's not exactly duplicate, KDE 4.4 is also needed and not mentioned in 575248 (KDE 4.3 won't work with Qt 4.6).
Comment 5 Ngo Than 2010-05-12 07:36:39 EDT
could you please give more detailts why KDE 4.3 won't work with Qt 4.6?

thanks
Comment 6 Brandon 2010-05-12 19:52:01 EDT
A few reasons:

- kdebindings doesn't build.

- PyKDE4 alone probably can build, if you disable all the other stuff.

- Ruby binding generator has changed completely from 4.3 to 4.4 and the version in 4.3 chokes on Qt 4.6

- There's also some other assorted breakage with KDE 4.3 on Qt 4.6.

According to Kevin_Kofler in #fedora-kde, it was attempted in rawhide and they decided to wait for KDE 4.4 instead of fix all the breakage.
Comment 7 Ngo Than 2010-05-14 05:42:16 EDT
(In reply to comment #6)
> A few reasons:
> 
> - kdebindings doesn't build.
> 
> - PyKDE4 alone probably can build, if you disable all the other stuff.
> 
> - Ruby binding generator has changed completely from 4.3 to 4.4 and the version
> in 4.3 chokes on Qt 4.6
> 

It's a known issue and can backported from 4.4 if there's request from customers . I don't see problem here because we only support PyKDE4 in rhel6.

> - There's also some other assorted breakage with KDE 4.3 on Qt 4.6.
> 

we were aware of some breakage with KDE 4.3 on Qt 4.6, and we already backported some patches from 4.4 which fix these issues
Comment 8 Brandon 2010-05-14 07:54:25 EDT
There will be a lot of backporting required as some of these KDE technologies mature based upon all of the stepping stones implemented in 4.4

The GetHotNewStuff interface has been changed because the framework has been updated. 

I don't see why so much effort should be put into making all these new things work with an old version (4.3) when 4.4 was stable enough to become a regular update in Fedora 12, no experimental repo required.

Note You need to log in before you can comment on or make changes to this bug.