Bug 590457 - RC2 livecd wlan0 not connect broadcom 4318
Summary: RC2 livecd wlan0 not connect broadcom 4318
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-09 16:28 UTC by Cia Watson
Modified: 2010-05-11 16:02 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 16:02:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from dmesg and other output (1.92 KB, text/plain)
2010-05-09 22:19 UTC, Cia Watson
no flags Details

Description Cia Watson 2010-05-09 16:28:15 UTC
Description of problem:
Booted to the RC2 livecd on an ibm thinkpad 600x (PIII) with a broadcom 4312 linksys wireless adapter and no Network Manager available to view wireless networks. Wired connection on a desktop pc works ok.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results: ifconfig showed a wlan0, but no inetaddr and ifup wlan0 said there wasn't a configuration file. Attempt to start Network Manager daemon failed. 


Expected results: Fedora 12 livecd wireless did work on the same laptop. 


Additional info:

Comment 1 Cia Watson 2010-05-09 22:19:58 UTC
Created attachment 412680 [details]
output from dmesg and other output

Booted again to the livecd and got some output from dmesg and other output -- including info. from abrt output I pasted to clipboard, in case it's relevant to this issue.

Comment 2 Adam Williamson 2010-05-10 12:05:29 UTC
you're using b43 with the open firmware, which is fairly experimental and certainly not a release blocker if it doesn't work, I'm afraid. You can try b43 with firmware extracted from an official Broadcom Windows driver with b43-fwcutter, or there is a proprietary Broadcom driver called 'wl' available from third-party repositories.

Assigning to kernel for now, if it works with b43+proprietary firmware, it should be assigned to b43-openfwwf.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 John W. Linville 2010-05-10 13:15:12 UTC
Well, actually it looks to me like the driver loaded and is sitting there happily -- at least from the info I can see.  Have you attempted to configure the driver manually, usin commands like "iwconfig", "iwlist", and/or "wpa_supplicant"?

"no Network Manager available", "Attempt to start Network Manager daemon failed", and "/sbin/ifup: configuration for wlan0 not found" seem more relevant to me.  Do you have any logs (perhaps something from /var/log/messages) that indicate why NetworkManager is unhappy?

Comment 4 Adam Williamson 2010-05-10 14:30:59 UTC
oops, sorry John, clearly my log-reading foo was not up to scratch this morning, the reporter did originally file against NM :(. still, let's find out for sure what the issue is before reassigning again :)

Comment 5 Adam Williamson 2010-05-10 15:05:14 UTC
There's more info in the OP's forum post:

"Is there no Network Manager on the livecd? When I tried to start it on i686 livecd, it failed trying to start the daemon. Also on the system > Admin menu there wasn't a network option.

I tried it (and it booted and came to a desktop) on my old ibm thinkpad with a PIII processor, with a broadcom 4312 wireless adapter. In a terminal I typed ifconfig and it saw the wlan0 but there wasn't an inet addr and ifup wlan0 said there wasn't a configuration found for it.

I could bring it into this room and plug in an eth0 connection, but if there's no network manager that won't make a difference? I'm hesitant to try to install if networking isn't going to work."

So it seems the NM service had trouble starting, for some reason. Reporter, what happens if you run 'service NetworkManager start' as root?

Comment 6 Cia Watson 2010-05-10 16:20:50 UTC
I didn't actually install to hard drive from the livecd, and when I booted it
this morning a NM icon did show up on the desktop. The desktop crashed and on a
second boot the icon wasn't there, but it may just be an issue with an old
laptop. I'm familiar with using b43 drivers from linuxwireless to get the
wireless working on this machine, so if or when I install to hard drive I'll go
that route if it doesn't work otherwise. 

When I looked at /var/log/messages the last thing it shows in relation to
Network Manager is: <info> (wlan0): supplicant interface state: starting ->
ready 

I can report back when I install to hard drive (maybe later tonight, can't do
it now) or you can close this bug report. Based on your comment above AdamW I tried restarting NetworkManager b/c it appears to be working and it said it 'can't remove /var/run/NetworkManager/NetworkManager.pid : permission denied' but this is still as a liveuser / root login.

Comment 7 Cia Watson 2010-05-11 16:02:42 UTC
My 2 attempts to install the livecd to hard drive weren't successful, the first time it was very close to the end after copying the live image and the desktop crashed. On one of the subsequent reboots the NM icon did show up and it did show wireless networks, so this bug report can be closed. (I'll try closing it myself, if not successful someone else please close it?)


Note You need to log in before you can comment on or make changes to this bug.