Bug 590458 - "Creating GPG Keys Using the Command Line" wiki page offers incomplete instructions
Summary: "Creating GPG Keys Using the Command Line" wiki page offers incomplete instru...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: fedora-websites
Version: devel
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: eric@christensenplace.us
QA Contact: Karsten Wade
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 590493
TreeView+ depends on / blocked
 
Reported: 2010-05-09 16:28 UTC by Jim Campbell
Modified: 2010-05-09 20:33 UTC (History)
2 users (show)

(edit)
Clone Of:
: 590493 (view as bug list)
(edit)
Last Closed: 2010-05-09 20:33:37 UTC


Attachments (Terms of Use)

Description Jim Campbell 2010-05-09 16:28:52 UTC
Description of problem:
This Fedora-docs wiki page ( http://fedoraproject.org/wiki/DocsProject/UsingGpg/CreatingKeys#Creating_GPG_Keys_Using_the_Command_Line ) suggests that users create a key by entering "gpg --gen-key" but the text instructions beneath that are incomplete.

A bit lower, the screen output shows:

Please select what kind of key you want:
(1) DSA and ElGamal (default)
(2) DSA (sign only)
(4) RSA (sign only)
Your selection?


Option #3 is missing, and option #1 is not the correct default option.  The following is actually displayed by the terminal:

Please select what kind of key you want:
   (1) RSA and RSA (default)
   (2) DSA and Elgamal
   (3) DSA (sign only)
   (4) RSA (sign only)
Your selection? 

This is a bit problematic because the following wiki instructions suggest that the default option is the correct option.  


Version-Release number of selected component (if applicable):

I think this would fall under:
Name       : pgp-tools
Arch       : i686
Version    : 1.1
Release    : 4.fc13


How reproducible:

Always


Steps to Reproduce:
1. Visit the wiki page - view incorrect text
  
Actual results:
As above

Expected results:
Correctly display the available options and let the reader know which is the preferred option to choose.

Additional info:
I didn't see a place to attach this bug to the wiki, so I hope setting it to "fedora-websites" is correct.

See here for a snapshot of the relevant text: http://www.imagebanana.com/img/dj6d8nt8/Selection_006.png

Comment 1 eric@christensenplace.us 2010-05-09 20:08:40 UTC
It's a wiki so feel free to change it yourself.  The wiki is for community changes.

Comment 2 Jim Campbell 2010-05-09 20:33:37 UTC
Thanks, Eric.  Given the importance of GPG keys, I wanted to err on the safe side, but I've gone ahead and made the corrections to the wiki page.

I've also marked the bug as closed.


Note You need to log in before you can comment on or make changes to this bug.