Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 590460 - [anaconda] [zh_CN] Incorrect translation
[anaconda] [zh_CN] Incorrect translation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Translation
Depends On:
Blocks: 527925
  Show dependency treegraph
 
Reported: 2010-05-09 12:43 EDT by Qian Cai
Modified: 2010-11-10 14:43 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-13.21.68-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:43:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (308 bytes, patch)
2010-05-09 12:44 EDT, Qian Cai
no flags Details | Diff
zh_CN - Screenshot FIXED word (14.02 KB, image/png)
2010-08-15 06:00 EDT, A S Alam
no flags Details

  None (edit)
Description Qian Cai 2010-05-09 12:43:54 EDT
Description of problem:
提交 = file verb (STORE/RECORD INFORMATION);
文件 = file noun

Version-Release number of selected component (if applicable):
13.21.30
Comment 1 Qian Cai 2010-05-09 12:44:30 EDT
Created attachment 412660 [details]
proposed patch
Comment 2 RHEL Product and Program Management 2010-05-09 13:20:35 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Chris Lumens 2010-05-10 11:20:35 EDT
Can you get this patch in through transifex?  Make sure it gets applied to both rhel6-branch and master.  Thanks.
Comment 5 David Cantrell 2010-05-10 19:32:46 EDT
This patch is small enough that I think we can just toss it in for master and rhel6-branch.
Comment 6 Qian Cai 2010-05-11 22:31:38 EDT
(In reply to comment #3)
> Can you get this patch in through transifex?  Make sure it gets applied to both
> rhel6-branch and master.  Thanks.    
Is this a needinfo from me? I am not familiar with transifex.
Comment 7 Tommy He 2010-05-13 04:44:50 EDT
Fixed po files were submitted to master and thel6 branches.

Thanks for reporting.
Comment 8 RHEL Product and Program Management 2010-07-15 10:04:45 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 9 Brian Lane 2010-07-15 11:43:31 EDT
Note, this is still an issue as far as I can tell. It looks like a transifex commit dce88c8b un-did the change that Tommy made.
Comment 10 RHEL Product and Program Management 2010-07-15 12:17:55 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 11 Tommy He 2010-07-15 16:18:18 EDT
(In reply to comment #9)
> Note, this is still an issue as far as I can tell. It looks like a transifex
> commit dce88c8b un-did the change that Tommy made.    

OK...what should I do now? Rolling back the commit?
Comment 13 Ankit Patel 2010-08-03 09:11:04 EDT
Hi all,

Since it's a translation issue, it has to go through proper channel (localization team -> zh_CN translator).

Assigning it to Leah Liu, who's in charge of handling zh_CN translations. She will take the necessary actions.

Thanks!
Ankit
Comment 14 Wei Liu 2010-08-04 03:52:49 EDT
The translation is modified to '提交' as the word 'File' here is a verb instead of noun.

Thanks
Leah
Comment 16 Ankit Patel 2010-08-04 04:08:16 EDT
if there is some problem with zh-CN, Leah Liu is still in the CC watch list.
Comment 17 David Cantrell 2010-08-04 10:26:26 EDT
The zh_CN.po file has been broken recently and we have to either revert the changes or fix up the file so the builds can complete.

The problem that keeps happening is for plural format strings where there is a singular and plural translation choice.  For example, line 575 in po/zh_CN.po keeps breaking.  Here is what ends up in the translation file:

#: installinterfacebase.py:47
#, python-format
msgid ""
"Disk %s contains BIOS RAID metadata, but is not part of any recognized BIOS "
"RAID sets. Ignoring disk %s."
msgid_plural ""
"Disks %s contain BIOS RAID metadata, but are not part of any recognized BIOS "
"RAID sets. Ignoring disks %s."
msgstr[0] ""
"磁盘 %s 中包含 BIOS RAID 元数据,但该数据不包含在任何可识别 BIOS 组中。"
"忽略磁盘 %s。"
msgstr[1] ""
""

The problem here is the msgstr[1] part.  You cannot have "" as the string because the msgid has format strings in it.  Even if the string is the same for this language, it needs to be duplicated.  Copying the string from msgstr[0] to msgstr[1] allows our build to complete, so we change it to:

msgstr[1] ""
"磁盘 %s 中包含 BIOS RAID 元数据,但该数据不包含在任何可识别 BIOS 组中。"
"忽略磁盘 %s。"

Please make sure that translations are complete when you commit them to the git repository.  We cannot continue to fix up the po files, we will have to start reverting changes to ensure the builds succeed.
Comment 18 Ankit Patel 2010-08-04 10:34:58 EDT
(In reply to comment #17)
> The zh_CN.po file has been broken recently and we have to either revert the
> changes or fix up the file so the builds can complete.
> 
> The problem that keeps happening is for plural format strings where there is a
> singular and plural translation choice.  For example, line 575 in po/zh_CN.po
> keeps breaking.  Here is what ends up in the translation file:
> 
> #: installinterfacebase.py:47
> #, python-format
> msgid ""
> "Disk %s contains BIOS RAID metadata, but is not part of any recognized BIOS "
> "RAID sets. Ignoring disk %s."
> msgid_plural ""
> "Disks %s contain BIOS RAID metadata, but are not part of any recognized BIOS "
> "RAID sets. Ignoring disks %s."
> msgstr[0] ""
> "磁盘 %s 中包含 BIOS RAID 元数据,但该数据不包含在任何可识别 BIOS 组中。"
> "忽略磁盘 %s。"
> msgstr[1] ""
> ""
> 
> The problem here is the msgstr[1] part.  You cannot have "" as the string
> because the msgid has format strings in it.  Even if the string is the same for
> this language, it needs to be duplicated.  Copying the string from msgstr[0] to
> msgstr[1] allows our build to complete, so we change it to:
> 
> msgstr[1] ""
> "磁盘 %s 中包含 BIOS RAID 元数据,但该数据不包含在任何可识别 BIOS 组中。"
> "忽略磁盘 %s。"
> 
> Please make sure that translations are complete when you commit them to the git
> repository.  We cannot continue to fix up the po files, we will have to start
> reverting changes to ensure the builds succeed.    


HI David,

Perhaps you haven't synched the zh_CN.po file from the git repo (rhel6-branch). Could you please check again. Because the corrected file is already submitted by Leah Liu this morning.

See the commit diff: http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=6ef0e970bfa1e180219a9a36e2fa9975c8b83c42
and the actual file: https://translate.fedoraproject.org/projects/p/anaconda/c/rhel6-branch/view/po/zh_CN.po

Thanks!
Ankit
Comment 19 Chris Lumens 2010-08-04 11:43:36 EDT
We pull all updated translations automatically before doing builds, so this will get pulled in.  I did a test build and it looks good now.  Thanks for fixing.
Comment 20 David Cantrell 2010-08-04 11:54:24 EDT
Looks like the zh_CN changes were pushed after we built yesterday (which makes sense given the time zones that we all work in).  The updated zh_CN.po file will be in the next build, which will be anaconda-13.21.68-1.
Comment 22 Kenichi Takemura 2010-08-08 21:29:31 EDT
Hi I am trying to verify this translation.

Which screen are you mentioning this bug?

Can you tell me the steps to verify?
Comment 23 A S Alam 2010-08-15 06:00:04 EDT
Created attachment 438813 [details]
zh_CN - Screenshot FIXED word
Comment 24 A S Alam 2010-08-15 06:08:40 EDT
status - FIXED
tested package: anaconda-13.21.74-1.el6.x86_64

detail: Screenshot
Comment 25 releng-rhel@redhat.com 2010-11-10 14:43:13 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.