Bug 590465 - SELinux is preventing /usr/bin/gcm-apply "write" access on /var/run/cups/cups.sock.
SELinux is preventing /usr/bin/gcm-apply "write" access on /var/run/cups...
Status: CLOSED DUPLICATE of bug 588295
Product: Fedora
Classification: Fedora
Component: gnome-color-manager (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:cc5b35163bb...
:
: 590464 591859 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 13:14 EDT by Paul Lipps
Modified: 2010-05-18 08:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 08:47:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Lipps 2010-05-09 13:14:56 EDT
Summary:

SELinux is preventing /usr/bin/gcm-apply "write" access on
/var/run/cups/cups.sock.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gcm-apply. It is not expected that this
access is required by gcm-apply and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cupsd_var_run_t:s0
Target Objects                /var/run/cups/cups.sock [ sock_file ]
Source                        gcm-apply
Source Path                   /usr/bin/gcm-apply
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-color-manager-2.30.1-2.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-13.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.3-85.fc13.x86_64 #1
                              SMP Thu May 6 18:09:49 UTC 2010 x86_64 x86_64
Alert Count                   7
First Seen                    Wed 14 Apr 2010 07:52:19 PM CDT
Last Seen                     Sun 09 May 2010 12:10:36 PM CDT
Local ID                      627e97de-0415-4b9c-ab84-bab3d0c43cea
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273425036.863:6): avc:  denied  { write } for  pid=1658 comm="gcm-apply" name="cups.sock" dev=dm-0 ino=261418 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cupsd_var_run_t:s0 tclass=sock_file

node=(removed) type=AVC msg=audit(1273425036.863:6): avc:  denied  { connectto } for  pid=1658 comm="gcm-apply" path="/var/run/cups/cups.sock" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tclass=unix_stream_socket

node=(removed) type=SYSCALL msg=audit(1273425036.863:6): arch=c000003e syscall=42 success=yes exit=4294967424 a0=f a1=c3b2d8 a2=1a a3=7fff50ec5f44 items=0 ppid=1 pid=1658 auid=4294967295 uid=42 gid=477 euid=42 suid=42 fsuid=42 egid=477 sgid=477 fsgid=477 tty=(none) ses=4294967295 comm="gcm-apply" exe="/usr/bin/gcm-apply" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gcm-apply,xdm_t,cupsd_var_run_t,sock_file,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t cupsd_t:unix_stream_socket connectto;
allow xdm_t cupsd_var_run_t:sock_file write;
Comment 1 Carl G. 2010-05-09 16:00:37 EDT
*** Bug 590464 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2010-05-10 09:40:15 EDT
gcm should not be communicating with cups
Comment 3 Richard Hughes 2010-05-10 10:36:39 EDT
I'm kinda confused why it's trying to use CUPS at all. Is httpInitialize enough to get the AVC?
Comment 4 Daniel Walsh 2010-05-10 12:23:26 EDT
I think it is the sane_init that is causing these.
Comment 5 Richard Hughes 2010-05-11 04:48:13 EDT
Could you try this build please: http://koji.fedoraproject.org/koji/buildinfo?buildID=172883

Thanks.
Comment 6 Richard Hughes 2010-05-13 09:24:48 EDT
*** Bug 591859 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Walsh 2010-05-18 08:47:44 EDT

*** This bug has been marked as a duplicate of bug 588295 ***

Note You need to log in before you can comment on or make changes to this bug.