Bug 590467 - SELinux is preventing /usr/bin/gcm-apply "connectto" access on /var/run/cups/cups.sock.
SELinux is preventing /usr/bin/gcm-apply "connectto" access on /var/run/...
Status: CLOSED DUPLICATE of bug 585723
Product: Fedora
Classification: Fedora
Component: gnome-color-manager (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:626910f684f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 13:16 EDT by Paul Lipps
Modified: 2010-06-15 06:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 14:24:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Lipps 2010-05-09 13:16:07 EDT
Summary:

SELinux is preventing /usr/bin/gcm-apply "connectto" access on
/var/run/cups/cups.sock.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gcm-apply. It is not expected that this
access is required by gcm-apply and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Objects                /var/run/cups/cups.sock [ unix_stream_socket ]
Source                        gcm-apply
Source Path                   /usr/bin/gcm-apply
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-color-manager-2.30.1-2.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-13.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux vbox-fedora13beta 2.6.33.3-85.fc13.x86_64 #1
                              SMP Thu May 6 18:09:49 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sun 09 May 2010 12:10:39 PM CDT
Last Seen                     Sun 09 May 2010 12:10:39 PM CDT
Local ID                      f8065c94-540f-4e3c-a144-0cc899d7b6f1
Line Numbers                  

Raw Audit Messages            

node=vbox-fedora13beta type=AVC msg=audit(1273425039.109:7): avc:  denied  { connectto } for  pid=1684 comm="gcm-apply" path="/var/run/cups/cups.sock" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tclass=unix_stream_socket

node=vbox-fedora13beta type=SYSCALL msg=audit(1273425039.109:7): arch=c000003e syscall=42 success=yes exit=4294967424 a0=f a1=17c12d8 a2=1a a3=7fff132e36c4 items=0 ppid=1 pid=1684 auid=4294967295 uid=42 gid=477 euid=42 suid=42 fsuid=42 egid=477 sgid=477 fsgid=477 tty=(none) ses=4294967295 comm="gcm-apply" exe="/usr/bin/gcm-apply" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gcm-apply,xdm_t,cupsd_t,unix_stream_socket,connectto
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t cupsd_t:unix_stream_socket connectto;
Comment 1 Daniel Walsh 2010-05-10 14:24:01 EDT

*** This bug has been marked as a duplicate of bug 585723 ***

Note You need to log in before you can comment on or make changes to this bug.